summaryrefslogtreecommitdiff
path: root/dev-python/pyClamd/pyClamd-0.4.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/pyClamd/pyClamd-0.4.0-r3.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/pyClamd/pyClamd-0.4.0-r3.ebuild')
-rw-r--r--dev-python/pyClamd/pyClamd-0.4.0-r3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pyClamd/pyClamd-0.4.0-r3.ebuild b/dev-python/pyClamd/pyClamd-0.4.0-r3.ebuild
new file mode 100644
index 000000000000..d89fe08eb48f
--- /dev/null
+++ b/dev-python/pyClamd/pyClamd-0.4.0-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="python interface to Clamd (Clamav daemon)"
+HOMEPAGE="https://xael.org/pages/pyclamd-en.html"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+# Tests need clamd running and we cannot rely on that being
+# true during build
+RESTRICT="test"