summaryrefslogtreecommitdiff
path: root/dev-python/py/py-1.4.34.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/py/py-1.4.34.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/py/py-1.4.34.ebuild')
-rw-r--r--dev-python/py/py-1.4.34.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/py/py-1.4.34.ebuild b/dev-python/py/py-1.4.34.ebuild
deleted file mode 100644
index ab63400bdc09..000000000000
--- a/dev-python/py/py-1.4.34.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
-HOMEPAGE="https://pylib.readthedocs.io/en/latest/ https://pypi.org/project/py/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-RDEPEND=""
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.4.34-skip-broken-pytest3.patch )
-
-python_prepare_all() {
- sed -e 's:intersphinx_mapping:#&:' -i doc/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- # 1 failure, test_comments, under both pypy only.
- # Also appears the home repo has no issue tracker.
- [[ "${EPYTHON}" == pypy ]] && return
- py.test -v -v || die "testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}