summaryrefslogtreecommitdiff
path: root/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild')
-rw-r--r--dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild b/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild
new file mode 100644
index 000000000000..4c6bb23e9adb
--- /dev/null
+++ b/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal Binary JSON encoder/decoder"
+HOMEPAGE="
+ https://github.com/Iotic-Labs/py-ubjson/
+ https://pypi.org/project/py-ubjson/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~riscv x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s test
+}