summaryrefslogtreecommitdiff
path: root/dev-python/py-cpuinfo/py-cpuinfo-9.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 09:55:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 09:55:31 +0100
commit9a8514e070a40648dbc8e28ad6457d925542b79a (patch)
tree5cc8ed0b0c8964ad196b7b3e502def202a997b32 /dev-python/py-cpuinfo/py-cpuinfo-9.0.0.ebuild
parent2ecd7994be1409f2a65bfca700904d2a78fd7bbe (diff)
gentoo auto-resync : 26:10:2022 - 09:55:31
Diffstat (limited to 'dev-python/py-cpuinfo/py-cpuinfo-9.0.0.ebuild')
-rw-r--r--dev-python/py-cpuinfo/py-cpuinfo-9.0.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/py-cpuinfo/py-cpuinfo-9.0.0.ebuild b/dev-python/py-cpuinfo/py-cpuinfo-9.0.0.ebuild
new file mode 100644
index 000000000000..44d377ce96c7
--- /dev/null
+++ b/dev-python/py-cpuinfo/py-cpuinfo-9.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Get CPU info with pure Python 2 & 3"
+HOMEPAGE="
+ https://github.com/workhorsy/py-cpuinfo/
+ https://pypi.org/project/py-cpuinfo/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests unittest