summaryrefslogtreecommitdiff
path: root/dev-python/puremagic/puremagic-1.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-07 09:58:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-07 09:58:54 +0000
commitd21e32f3fcb95019b77ca3f1a6d710ea7f9f1e04 (patch)
tree2933229277b445ec8521fc81053c1442c9f1f7b9 /dev-python/puremagic/puremagic-1.20.ebuild
parent632aa90c53a31517c5d2259537aadc192434a332 (diff)
gentoo auto-resync : 07:02:2024 - 09:58:54
Diffstat (limited to 'dev-python/puremagic/puremagic-1.20.ebuild')
-rw-r--r--dev-python/puremagic/puremagic-1.20.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/puremagic/puremagic-1.20.ebuild b/dev-python/puremagic/puremagic-1.20.ebuild
new file mode 100644
index 000000000000..bf7bf4cdb98b
--- /dev/null
+++ b/dev-python/puremagic/puremagic-1.20.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python implementation of magic file detection"
+HOMEPAGE="
+ https://github.com/cdgriffith/puremagic/
+ https://pypi.org/project/puremagic/
+"
+SRC_URI="
+ https://github.com/cdgriffith/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CHANGELOG.md README.rst )
+
+distutils_enable_tests pytest