summaryrefslogtreecommitdiff
path: root/dev-python/pudge/pudge-0.1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pudge/pudge-0.1.3-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pudge/pudge-0.1.3-r1.ebuild')
-rw-r--r--dev-python/pudge/pudge-0.1.3-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pudge/pudge-0.1.3-r1.ebuild b/dev-python/pudge/pudge-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..77ed500a2342
--- /dev/null
+++ b/dev-python/pudge/pudge-0.1.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A documentation generator for Python projects, using Restructured Text"
+HOMEPAGE="http://pudge.lesscode.org https://pypi.org/project/pudge/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+RDEPEND="dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/kid-0.9.5[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( ${RDEPEND} )"
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation"
+ "${PYTHON}" bin/pudge --modules=pudge --documents=doc/index.rst --dest=doc/html \
+ || die "Generation of documentation failed"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+}