summaryrefslogtreecommitdiff
path: root/dev-python/ptpython/ptpython-0.33.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/ptpython/ptpython-0.33.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/ptpython/ptpython-0.33.ebuild')
-rw-r--r--dev-python/ptpython/ptpython-0.33.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/ptpython/ptpython-0.33.ebuild b/dev-python/ptpython/ptpython-0.33.ebuild
new file mode 100644
index 000000000000..b1c5fb77f83f
--- /dev/null
+++ b/dev-python/ptpython/ptpython-0.33.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python REPL build on top of prompt_toolkit"
+HOMEPAGE="https://pypi.python.org/pypi/ptpython/ https://github.com/jonathanslenders/ptpython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-0.58[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Not included
+RESTRICT=test
+
+python_test() {
+ "${PYTHON}" tests/run_tests.py || die
+}