summaryrefslogtreecommitdiff
path: root/dev-python/psycopg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-13 21:28:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-13 21:28:20 +0000
commitb9d995791a762215ef1ced2cc1a47b8d3c2cff1a (patch)
treeceff6a3b47b9258682735a5595c9ee8a0427a445 /dev-python/psycopg
parent50098d976449286058396cebad0087e28f771b90 (diff)
gentoo auto-resync : 13:12:2022 - 21:28:20
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/Manifest2
-rw-r--r--dev-python/psycopg/psycopg-3.1.5.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/psycopg/Manifest b/dev-python/psycopg/Manifest
index b99c7470930a..bb17ccc7dfd5 100644
--- a/dev-python/psycopg/Manifest
+++ b/dev-python/psycopg/Manifest
@@ -1,5 +1,7 @@
DIST psycopg-3.1.4.gh.tar.gz 469317 BLAKE2B a6df49a5adefbeb310602473e950ef77f0c613d8a33d41ee37dbfec544dfd014dba8dae5f78ce2bc89f2d9531ccbdd6ea07665ca638f29a4a7d0d1006bc0d778 SHA512 2bf49d6eb7e20c6f22adf47cef6dce691f38f4b310f2fbf3986f3ad14c7d390d53b9edeb3365bbf096941cc2d2affe2ddd542fe93ef37c41109742c9f9af4ba7
+DIST psycopg-3.1.5.gh.tar.gz 478528 BLAKE2B f0e6d1970b81875481bf0939d750d585f9ce4be1ccf838d1884a54d366614ec1ca76756b455d28b559ef4f49696eda68fa3b42f8c0cc18d9ce9fd1ce21029830 SHA512 006a9a6b7d34ed6f0411c33001334b9e9d29c8d1fe5e9e3b940d5664cc5c06ce10bc278ee1906a96073843ca2f8effaada8789aa390de97e543e19cc452546d1
DIST psycopg2-2.9.4.tar.gz 384017 BLAKE2B 4bc0afcc890c8a257c1ccd5c6e4e5301857a80f8b1428aa46c1473c9e18f5d2914a2e592c13336b06106217bb334d9b0321835bdd123f1627cbeb29dedf97bf7 SHA512 259088e42e0ab0d8a1a0ccf04f5e560f32c6179b4a0a0059e91bcf269baa8f4b0f1f949c332c640a2438c927a29b2c144078a861f8e18ba9c764da7c93c73b8d
EBUILD psycopg-2.9.4.ebuild 1341 BLAKE2B b15c8cbba716e477b2abdab49b2926c66ebf2a041398e2182450cdf5a8cdfecf23d955f557f5ab270d393116f77482d4572995dbf9be0b174fc127cfadb1f6e7 SHA512 c801cf840907a22566854ded036febc066fa42ef017bef2cfb45d5c7d9774a4f6aad0751769f74755d6b5c4dc2d24f51a1761d07e1cf66737145ecb1bc56c9fb
EBUILD psycopg-3.1.4.ebuild 1725 BLAKE2B c78cc5299f68452a34fedef960e3ad1bab4d2ab350e06717813bb6972bc0b71c138d1b7d8da12fbea9c36d6b107d9be137e278d43e3a31e74a9fb0df09cbb404 SHA512 2efabffff8d9ae101f2207e694f60bb47daa54454274c8c7abfd69e7b21189628c088e9f8b2677a8bb2a9dde4a345abb165a538a35be7c7dc436a0f886b88ed0
+EBUILD psycopg-3.1.5.ebuild 1732 BLAKE2B 346e6e31a3be765833c4a1d75009d3c8e7347aea9a4a38d35d0cc5c7da722d23abfc41c5b4943331a008b19238a7544c0b181eec83a23a68ae1bc68e5748757f SHA512 f808046857d7400d55ebd1e10ab5f090c26f78b181ded703798acd5a9531bff61bbb450350f904533e265f0fcd2c5032db53a9c1503ced826dc26002cc2a844e
MISC metadata.xml 369 BLAKE2B 042788638a82318248d4e4ea1e12bf1631af6ffc435fc0110e13849dad600854e8b57f5ba3397c4d4e5d103e165b342f8aba869e72e9b63efc500382d3423414 SHA512 5b216575e8cae847f71a09ed6b676a73fccf2070f3bea3b35f1bfbde95fb0154b2fbb356948e112cc9f2298fc9868ac3994a139e72939f80d59c084ec58d80bf
diff --git a/dev-python/psycopg/psycopg-3.1.5.ebuild b/dev-python/psycopg/psycopg-3.1.5.ebuild
new file mode 100644
index 000000000000..8bd1346c397b
--- /dev/null
+++ b/dev-python/psycopg/psycopg-3.1.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="
+ https://www.psycopg.org/psycopg3/
+ https://github.com/psycopg/psycopg/
+ https://pypi.org/project/psycopg/
+"
+SRC_URI="
+ https://github.com/psycopg/psycopg/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${P}/psycopg
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+DEPEND="
+ >=dev-db/postgresql-8.1:*
+"
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/backports-zoneinfo-0.2.0[${PYTHON_USEDEP}]
+ ' 3.8)
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-db/postgresql-8.1[server]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tests for the psycopg_pool package
+ tests/pool
+ # some broken mypy magic
+ tests/test_module.py::test_version
+ tests/test_module.py::test_version_c
+ tests/test_typing.py
+ tests/crdb/test_typing.py
+ # TODO, relying on undefined ordering in Python?
+ tests/test_dns_srv.py::test_srv
+)
+
+src_test() {
+ # tests are lurking in top-level directory
+ cd .. || die
+
+ initdb -D "${T}"/pgsql || die
+ # TODO: random port
+ pg_ctl -w -D "${T}"/pgsql start \
+ -o "-h '' -k '${T}'" || die
+ createdb -h "${T}" test || die
+
+ local -x PSYCOPG_TEST_DSN="host=${T} dbname=test"
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${T}"/pgsql stop || die
+}