summaryrefslogtreecommitdiff
path: root/dev-python/psycopg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-02 10:16:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-02 10:16:02 +0100
commit02fbebe9426ee05ab39e9b5a56e3529e64160ef6 (patch)
tree4c2a5db6966711f46fbc73aece931b17625e27b7 /dev-python/psycopg
parentb052fbf151106a4f47cac7fdf0ffff983decb773 (diff)
gentoo auto-resync : 02:09:2022 - 10:16:01
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/Manifest2
-rw-r--r--dev-python/psycopg/psycopg-3.1.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/psycopg/Manifest b/dev-python/psycopg/Manifest
index 099cb8a4a21a..79633b9f53f8 100644
--- a/dev-python/psycopg/Manifest
+++ b/dev-python/psycopg/Manifest
@@ -1,5 +1,7 @@
DIST psycopg-3.0.16.gh.tar.gz 386693 BLAKE2B c6c0bd9832e65180e7de76b04ef7c81f4c2d0981894d090b933ce0efaaafdf6b62d1d71a4c70c7c9b848b67e576a71953116925f9e991a4ed99b53067e24cbba SHA512 655e01bb00972dacae590f2e8ce5948226acb827b55099e7f362fdee9210f07b755f4da10d2fadd468aa95eaa3f72e7658a1ab26870d4ac159ee266ce1f8140c
+DIST psycopg-3.1.gh.tar.gz 463892 BLAKE2B 94100bed4807771f6c4d0469737b160955f3f6bfcff84240c9e15dd9b7b88765583952b712642740c97f6ec42223edcf74fb2c5390a185f44ca0eb8858e76100 SHA512 057a14d614ccb9f36a7db7a82c3d48953658a1c6af2a2265a93a3f6c1db421275e51e1be4d59e2ea98b638f3da8c24c9d2a4d9aabf6190c47691dd632c9339f9
DIST psycopg2-2.9.3.tar.gz 380611 BLAKE2B 78099da7378dcfa8b7f28aae4d533a7e890cdb7ae4c0cc718a9411e630fd07b56f074760fc29de8fe08fe727328cca39414a5f297fb92ed2f7471a24e633d18d SHA512 048184d1d162a371fc0fba711448a6fa8a6aac193421f4484c7f7b91c39065d5b632fa34fc15a901eca055d597302b1f9e38330b248ed0e4653dcdc544b0d660
EBUILD psycopg-2.9.3.ebuild 1306 BLAKE2B 166f519f6e4694fb2725e0f4e736a9ab907dc398c4fadee579da96e37f29faf6f6fe735e56dc9156eefa74302bc516915499d827b3762655863bda1162716e19 SHA512 ecb1f931618b74393cace6f850b35c7512fe5902bdf97eadf0cc1f54e60797c863fe558cda3117ca8a5cd025bd6a761545d6fc1d837aed8ec095c48e98cd7c1b
EBUILD psycopg-3.0.16.ebuild 1653 BLAKE2B 91a5f64268d5304b46e14d3969bfb3a8df2fd1ebf6ca8d9adc365ce7200628efbe8d7c8bcf4e964881eeec743fb3c736ddf49f897df546161f053ed955284e58 SHA512 647f24602344c4016e440c4dc2d2c8247b5e6f549049140d9fcb03854d926bea1c1f494f836ab1f9f5be3f0239c680dd6cdc44fa14166981b149a2a1db707ed7
+EBUILD psycopg-3.1.ebuild 1732 BLAKE2B 346e6e31a3be765833c4a1d75009d3c8e7347aea9a4a38d35d0cc5c7da722d23abfc41c5b4943331a008b19238a7544c0b181eec83a23a68ae1bc68e5748757f SHA512 f808046857d7400d55ebd1e10ab5f090c26f78b181ded703798acd5a9531bff61bbb450350f904533e265f0fcd2c5032db53a9c1503ced826dc26002cc2a844e
MISC metadata.xml 369 BLAKE2B 042788638a82318248d4e4ea1e12bf1631af6ffc435fc0110e13849dad600854e8b57f5ba3397c4d4e5d103e165b342f8aba869e72e9b63efc500382d3423414 SHA512 5b216575e8cae847f71a09ed6b676a73fccf2070f3bea3b35f1bfbde95fb0154b2fbb356948e112cc9f2298fc9868ac3994a139e72939f80d59c084ec58d80bf
diff --git a/dev-python/psycopg/psycopg-3.1.ebuild b/dev-python/psycopg/psycopg-3.1.ebuild
new file mode 100644
index 000000000000..8bd1346c397b
--- /dev/null
+++ b/dev-python/psycopg/psycopg-3.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="
+ https://www.psycopg.org/psycopg3/
+ https://github.com/psycopg/psycopg/
+ https://pypi.org/project/psycopg/
+"
+SRC_URI="
+ https://github.com/psycopg/psycopg/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${P}/psycopg
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+DEPEND="
+ >=dev-db/postgresql-8.1:*
+"
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/backports-zoneinfo-0.2.0[${PYTHON_USEDEP}]
+ ' 3.8)
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-db/postgresql-8.1[server]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tests for the psycopg_pool package
+ tests/pool
+ # some broken mypy magic
+ tests/test_module.py::test_version
+ tests/test_module.py::test_version_c
+ tests/test_typing.py
+ tests/crdb/test_typing.py
+ # TODO, relying on undefined ordering in Python?
+ tests/test_dns_srv.py::test_srv
+)
+
+src_test() {
+ # tests are lurking in top-level directory
+ cd .. || die
+
+ initdb -D "${T}"/pgsql || die
+ # TODO: random port
+ pg_ctl -w -D "${T}"/pgsql start \
+ -o "-h '' -k '${T}'" || die
+ createdb -h "${T}" test || die
+
+ local -x PSYCOPG_TEST_DSN="host=${T} dbname=test"
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${T}"/pgsql stop || die
+}