summaryrefslogtreecommitdiff
path: root/dev-python/psutil/psutil-5.9.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-16 16:00:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-16 16:00:40 +0100
commit7f1592d914f244f1c2ab9e4bf84c003131f6d3b8 (patch)
tree7bce2dbb6156f707d739cb9fc044116fe4325dd6 /dev-python/psutil/psutil-5.9.6.ebuild
parent5a2a5572ac35843b9cd1c9369bd96e117647d24f (diff)
gentoo auto-resync : 16:10:2023 - 16:00:40
Diffstat (limited to 'dev-python/psutil/psutil-5.9.6.ebuild')
-rw-r--r--dev-python/psutil/psutil-5.9.6.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/psutil/psutil-5.9.6.ebuild b/dev-python/psutil/psutil-5.9.6.ebuild
new file mode 100644
index 000000000000..e28e2cda6093
--- /dev/null
+++ b/dev-python/psutil/psutil-5.9.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+TEST_PATCH=psutil-5.9.6-tests.patch
+DESCRIPTION="Retrieve information on running processes and system utilization"
+HOMEPAGE="
+ https://github.com/giampaolo/psutil/
+ https://pypi.org/project/psutil/
+"
+SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/${TEST_PATCH}.xz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${WORKDIR}/${TEST_PATCH}"
+)
+
+python_test() {
+ # Since we are running in an environment a bit similar to CI,
+ # let's skip the tests that are disabled for CI
+ local -x TRAVIS=1
+ local -x APPVEYOR=1
+ local -x GITHUB_ACTIONS=1
+ local -x GENTOO_TESTING=1
+ "${EPYTHON}" psutil/tests/runner.py ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_compile() {
+ # Force -j1 to avoid .o linking race conditions
+ local MAKEOPTS=-j1
+ distutils-r1_python_compile
+}