summaryrefslogtreecommitdiff
path: root/dev-python/protobuf-python/protobuf-python-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-21 21:44:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-21 21:44:48 +0100
commitd51fe7680c5270ddf8d324bbe11caab6d1e27ade (patch)
treea895b5889d79dbbb9aa52995fcac4816acfa07c1 /dev-python/protobuf-python/protobuf-python-9999.ebuild
parent7d52991b5dce3a07be15d3cbbf06abb3fc08cb9c (diff)
gentoo auto-resync : 21:08:2023 - 21:44:47
Diffstat (limited to 'dev-python/protobuf-python/protobuf-python-9999.ebuild')
-rw-r--r--dev-python/protobuf-python/protobuf-python-9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/protobuf-python/protobuf-python-9999.ebuild b/dev-python/protobuf-python/protobuf-python-9999.ebuild
index 6e644110d77b..ac61281fae8f 100644
--- a/dev-python/protobuf-python/protobuf-python-9999.ebuild
+++ b/dev-python/protobuf-python/protobuf-python-9999.ebuild
@@ -3,13 +3,14 @@
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
PARENT_PN="${PN/-python/}"
-PARENT_PV="${PV}"
+PARENT_PV="$(ver_cut 2-)"
PARENT_P="${PARENT_PN}-${PARENT_PV}"
if [[ "${PV}" == *9999 ]]; then
@@ -23,7 +24,7 @@ else
https://github.com/protocolbuffers/protobuf/archive/v${PARENT_PV}.tar.gz
-> ${PARENT_P}.tar.gz
"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~x64-macos"
fi
DESCRIPTION="Google's Protocol Buffers - Python bindings"
@@ -33,20 +34,18 @@ HOMEPAGE="
"
LICENSE="BSD"
-SLOT="0/32"
+SLOT="0/23.3.0"
S="${WORKDIR}/${PARENT_P}/python"
BDEPEND="
- dev-libs/protobuf:${SLOT}
- dev-python/six[${PYTHON_USEDEP}]
"
DEPEND="
${PYTHON_DEPS}
- dev-libs/protobuf:${SLOT}
"
RDEPEND="
${BDEPEND}
+ dev-libs/protobuf:${SLOT}
"
distutils_enable_tests setup.py