summaryrefslogtreecommitdiff
path: root/dev-python/proto-plus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-21 00:11:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-21 00:11:18 +0100
commitbed3b604e16fc6075e29f1af8d47507a07035bd3 (patch)
tree1f5d57fd86e90db37f62afb463f4b4c08a2b6eda /dev-python/proto-plus
parentd6ca4e4f90cb75c323b5988eefa96a04c0d36908 (diff)
gentoo auto-resync : 21:06:2024 - 00:11:18
Diffstat (limited to 'dev-python/proto-plus')
-rw-r--r--dev-python/proto-plus/Manifest2
-rw-r--r--dev-python/proto-plus/proto-plus-1.24.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index bc31566b8ced..277a1a94e55f 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -1,3 +1,5 @@
DIST proto-plus-python-1.23.0.gh.tar.gz 96752 BLAKE2B a971ef18b3513dcda0f2ea7a1eec8a1b76cc0094fdb73e7df1b258d0db7c16d2ef07152eff28c71e10456e2b9d2532da748901734d35a0245f99af7cf558866c SHA512 9e1566f6e3d2f99a37e7c5c9d3203a0073648f423112413d7d4fd61ebe38f175f30e1c4d2d24257acb7d09a685722b63960f9f686ede9ddb98a4c4463d5c0402
+DIST proto-plus-python-1.24.0.gh.tar.gz 100401 BLAKE2B 29094738e9c84559b8b51b078ecb059e7475c5c6e9392f23925c6df264efebd22c191c5b593fc659aabb20ce9cb0d93cde9df28b0b40aac4bbc80e075a95ec24 SHA512 3995df0a7df60a9a5c9325c29456f73d8482ae3d765f9553e5633b8d0ae0869c6fe3cd60e780f8fcd49d04470205abf621bc56c20d64252b76d51c19ff283372
EBUILD proto-plus-1.23.0.ebuild 888 BLAKE2B 2e0622a8ff3fd6d404d5f29b444fe71f75f3b84ff4e0b6cc6661b8fd324cf49c032618e5cfb0bbbe26558f2aa3168823fce417f6c5dd17c193c11f4436a06ef1 SHA512 de1cd88ff2d943a348b4be0ddaf1b46db2aeb168cc9d1c1e8479d6d474eb18624a5664d2cd3eab55e759d7fa5fce89ceac4b80744582d8e626203c1d5ac00ab2
+EBUILD proto-plus-1.24.0.ebuild 891 BLAKE2B 41315e233bb0c2fee4e795937e6114eba0bb96d3fdd3bd92286a0dc2d430985b6efc963fbe5a99ba6e5026109413958f6d31b16b2ba1f5c112055c0d926cdfbc SHA512 9d4d0d64ada3fcc5474028a63a4f0d4141cb52bfe3832f260505dfcfdcb260eaa6320dc83e75fd0a41eaeaa3650999b7dc25ecc8bd2b2903e458f304d1e30274
MISC metadata.xml 447 BLAKE2B d440be836b8a2823ab3beb7f76cbe7ff3f027ec512dff3f7d920eefea3f18329e1aa910ca16e006b1424cbd780f3fad80b8ccdc632c08ade651afd815369e9d0 SHA512 d64b8d2eeac9916ec2faab3b038082155e46e8c379ce06d7f554de763318539fa9040d15f90a3a95f337937c90f4b4042f51b1ea1cd11727e5fd971a0af5280c
diff --git a/dev-python/proto-plus/proto-plus-1.24.0.ebuild b/dev-python/proto-plus/proto-plus-1.24.0.ebuild
new file mode 100644
index 000000000000..ef8253d098dc
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.24.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${PN}-python-${PV}
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="
+ https://github.com/googleapis/proto-plus-python/
+ https://pypi.org/project/proto-plus/
+"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/google-api-core-1.31.5[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme