summaryrefslogtreecommitdiff
path: root/dev-python/proto-plus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-08 18:16:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-08 18:16:35 +0000
commit2237cda0c6b012952e02ec1314e1f48eddf4dab7 (patch)
tree0a7ab76265dc441f4b3436f07d019007e6a13237 /dev-python/proto-plus
parent6a57f9ee53dc794f3d47ea68f78d6ef76d00af47 (diff)
gentoo auto-resync : 08:01:2023 - 18:16:34
Diffstat (limited to 'dev-python/proto-plus')
-rw-r--r--dev-python/proto-plus/Manifest1
-rw-r--r--dev-python/proto-plus/proto-plus-1.22.1-r1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index 4ae1f02adb00..6317ccbdad2f 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -1,3 +1,4 @@
DIST proto-plus-1.22.1.gh.tar.gz 69507 BLAKE2B b71c263270dde979da0e050a21db258366ca5ddfaed5f8fb78e53444454a123d171019801873d1662ca73a89f079fa1c4cb7c58d34053cabb528015c0d742183 SHA512 2fb5dcb6124d6e2aab010089f4ad138de5cd819d4e67c2b9a6d7044a3d7677ca6e5e37e9aa0ee9edb262c52724dfd2dc05592c489df66d3cafbdf51f13644c7e
+EBUILD proto-plus-1.22.1-r1.ebuild 912 BLAKE2B 5f07367e3ba3125c7ad203df47952c8e74a34ecbc5187af4fcb6a9c461836346caac0d0e929af0aca07dd142d04c0eb9ab5f6cadff62401db9965ed11c3c0b8f SHA512 aab7691db7e4e8610d8d22d7dbda8f7b8d07bd3f2779273fd96e5aee6ee58bf5c95b9a12d2db6e9544f8e932210b7976a18410c740c3d357eb9a033fdb8392eb
EBUILD proto-plus-1.22.1.ebuild 917 BLAKE2B 7ebb9724e5e0fbfe88b3961912eea64bc61de0c47528fc34a4140b8d52a6891d5973bec31a46683690cefac235498ea55a45163ac5c7152bc479fa387d9913c6 SHA512 71e6499479714996cbb506f120802fc4ac1d437866c96df42a1a3515d9e30905ef25cfbfa2545a05ee015e106cefa962d834a2b76aa7532aa33560cba3e7411e
MISC metadata.xml 447 BLAKE2B d440be836b8a2823ab3beb7f76cbe7ff3f027ec512dff3f7d920eefea3f18329e1aa910ca16e006b1424cbd780f3fad80b8ccdc632c08ade651afd815369e9d0 SHA512 d64b8d2eeac9916ec2faab3b038082155e46e8c379ce06d7f554de763318539fa9040d15f90a3a95f337937c90f4b4042f51b1ea1cd11727e5fd971a0af5280c
diff --git a/dev-python/proto-plus/proto-plus-1.22.1-r1.ebuild b/dev-python/proto-plus/proto-plus-1.22.1-r1.ebuild
new file mode 100644
index 000000000000..a97f156bb73d
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.22.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1
+
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="
+ https://github.com/googleapis/proto-plus-python/
+ https://pypi.org/project/proto-plus/
+"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/google-api-core-1.31.5[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme