summaryrefslogtreecommitdiff
path: root/dev-python/prompt_toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /dev-python/prompt_toolkit
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'dev-python/prompt_toolkit')
-rw-r--r--dev-python/prompt_toolkit/Manifest2
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-2.0.6.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/Manifest b/dev-python/prompt_toolkit/Manifest
index 78f15f9838ec..4264d6a92a3c 100644
--- a/dev-python/prompt_toolkit/Manifest
+++ b/dev-python/prompt_toolkit/Manifest
@@ -1,3 +1,5 @@
DIST prompt_toolkit-1.0.15.tar.gz 243734 BLAKE2B b27e61bb444360abe95714e2014fcacf2355da0540b21af35cc40cb0f0115d0a3b027236235a89a95c1ec1fa947bf5b88b236b737fab5de78e7bd5fc798aa764 SHA512 10981be2ed8b71d0cd9f663c4de047cec9664d9276968c6eec40dc45b388d1acf8eba07d534369254f178931079bf39b04eb2ceac06aa63a2021ebf62387b2f5
+DIST prompt_toolkit-2.0.6.tar.gz 339714 BLAKE2B f969edef98d25930e4d61c1500bb9c8d731dea29e8d154e6baa2ab4045ceaf9d577d46024734a255cc15a4c13685582309e9d2fe7ae3320257f6fd1f9981ada6 SHA512 37082011ee5b8d6fd9febef95c92494ed6108b9ad8c64ac580b69c3464781a2f0dcef5b1c4d06fe309a3036932f7c622042e6b2293acf2ab6f9f2aa3c48d9322
EBUILD prompt_toolkit-1.0.15.ebuild 754 BLAKE2B a363862593748865fdd8c312cd5e2eb654bc04f8e73e0149a21b1752a2506d5f4ce07c9529971c7ffaf583bfa58d6aef45a8ad8d4186cdc1e0683b5df5ec2f93 SHA512 3f735e57d8893a89765e62aa1818bed08ea1b9a50efdf4f761bac5d43cc399ae0481627e53c8f4ac3b00aa90195a933f354bfa017ea69a36ef8e2f96dafee486
+EBUILD prompt_toolkit-2.0.6.ebuild 758 BLAKE2B 09e4f9d91eb9b8e252a7d665c156e903e35267bc83b35c85cd279eb05cef5c05c7bc3cf2426909afcfa42f7382fd6ff33893f20d314cacffa3848710c9885935 SHA512 fd33b49d741dd2282e31894f9e09348aa9fae700dc7cf7e91e76d5d6b6af175916a175b75df39e080c9f949ca6093f00365d8bfc5240756f57499e80f681f918
MISC metadata.xml 407 BLAKE2B a53543e0383cf16a19405b6722f7c5b430c69b0ac1a0863681ca700c56dba8e630f04e27fe682ecfaa905d6fb8ac4b4fbc78cbdc3e2575647071c2662ad5fe5a SHA512 7322ba928408db64bb54edf92fd385bd2fc41dea2a857bd2034d3b3e3bfe23b7fc82fd8048a41bb65f0aa103153e9f99f64c5f6abc76cc01a3d2db139b0a98ff
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-2.0.6.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-2.0.6.ebuild
new file mode 100644
index 000000000000..8bf3a1119b10
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-2.0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="https://pypi.org/project/prompt_toolkit/ https://github.com/jonathanslenders/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test || die
+}