summaryrefslogtreecommitdiff
path: root/dev-python/prompt-toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-05 10:11:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-05 10:11:02 +0100
commit20deac35b03e3e15d55e2cfd0236308f20bead59 (patch)
tree025d381424ca1c394c0f8e538633cd942f5ee490 /dev-python/prompt-toolkit
parentfc3556aa4466d278bff2aef2f88113089def0bab (diff)
gentoo auto-resync : 05:07:2023 - 10:11:01
Diffstat (limited to 'dev-python/prompt-toolkit')
-rw-r--r--dev-python/prompt-toolkit/Manifest2
-rw-r--r--dev-python/prompt-toolkit/prompt-toolkit-3.0.39.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/prompt-toolkit/Manifest b/dev-python/prompt-toolkit/Manifest
index 500def9d6db5..ef8ad370fece 100644
--- a/dev-python/prompt-toolkit/Manifest
+++ b/dev-python/prompt-toolkit/Manifest
@@ -1,3 +1,5 @@
DIST prompt_toolkit-3.0.38.tar.gz 422834 BLAKE2B 484ff9414d47f6f2188b8d50c6fcbe16ed850a8be880dfc60e9a3b750a26490f273b118d7bf0f1219530a59998273270b3b210750c35d00d7551ba15bb3f7e64 SHA512 eed2a73501d7ac413986f069564295db9eced3be4853a73c687e511ce1cf8c32c7c9bff4f851787e7910ed05818d4eb39556718c01f30e3ba8bfafe67d631a38
+DIST prompt_toolkit-3.0.39.tar.gz 423068 BLAKE2B d8673b3a9f4eb57c503e85471c13cefdb4f53fad58145d4198cd0f678d3f2d9d72d22d651b239386d8ade29c1fd155a98e80e4002b00ccbbbeff577636b9aa27 SHA512 6aaa80d515cd9731be1cc0de97f679b9dc22701dfb3e23b5434240aae0cac5eaede08437171a710492ff4041a9d46956cf8ed02750e9a78319eb61223033ba90
EBUILD prompt-toolkit-3.0.38.ebuild 592 BLAKE2B 4deb8f06135aa2b0ceac1d98f439a1a1ace799106a014b8a232a5b7de5603559dc25b48efe5372798964a5885f27504d99357d5990a6d9c4c83fe0a5c7a412c0 SHA512 8290dca4a3c9e6d06cbee643595a77b2f33160dfb57ac48550ab85f00d7a756bae3f76b3de70633e1d655d9e6ac4b1ac7d9930b60249068e89d04447694eae57
+EBUILD prompt-toolkit-3.0.39.ebuild 600 BLAKE2B 311003fac94c7a68ebe76bd7ca553ee449d00593c7e1c661ae7acb43c34da45c76f5b6fe1e9d3bd2cc06836ec58269fbd4ae1370e358c5694ae224e8edd5a0a5 SHA512 1310ff174d80c73ec83e61f07227939ff3ac3a5ec6b058f3c173410f638f365dc69bdd9db11ac97ef14c97cf784a2a8ebc6d21d87fbbe5d8e5f966d1a7ebec72
MISC metadata.xml 431 BLAKE2B 534336484c65b57df5e672729ff722b67445948e0485c3a62c2f7081724cb951b5157c600dc6162a3bb857c2be0f378b18670786279ff8b5cff2858588f8ebc9 SHA512 a9bf68326839069c61e70d4ef3fe304706f2543b9b91eb291566dd66f36d1abec00382ae205549a35f10dfc730f4613c5cc5c0ee4d6858538d50c4145bd3b15e
diff --git a/dev-python/prompt-toolkit/prompt-toolkit-3.0.39.ebuild b/dev-python/prompt-toolkit/prompt-toolkit-3.0.39.ebuild
new file mode 100644
index 000000000000..18f118d98d56
--- /dev/null
+++ b/dev-python/prompt-toolkit/prompt-toolkit-3.0.39.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest