summaryrefslogtreecommitdiff
path: root/dev-python/prompt-toolkit/prompt-toolkit-3.0.39.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-05 10:11:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-05 10:11:02 +0100
commit20deac35b03e3e15d55e2cfd0236308f20bead59 (patch)
tree025d381424ca1c394c0f8e538633cd942f5ee490 /dev-python/prompt-toolkit/prompt-toolkit-3.0.39.ebuild
parentfc3556aa4466d278bff2aef2f88113089def0bab (diff)
gentoo auto-resync : 05:07:2023 - 10:11:01
Diffstat (limited to 'dev-python/prompt-toolkit/prompt-toolkit-3.0.39.ebuild')
-rw-r--r--dev-python/prompt-toolkit/prompt-toolkit-3.0.39.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/prompt-toolkit/prompt-toolkit-3.0.39.ebuild b/dev-python/prompt-toolkit/prompt-toolkit-3.0.39.ebuild
new file mode 100644
index 000000000000..18f118d98d56
--- /dev/null
+++ b/dev-python/prompt-toolkit/prompt-toolkit-3.0.39.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest