summaryrefslogtreecommitdiff
path: root/dev-python/prometheus_client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /dev-python/prometheus_client
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'dev-python/prometheus_client')
-rw-r--r--dev-python/prometheus_client/Manifest2
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.1.1.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/prometheus_client/Manifest b/dev-python/prometheus_client/Manifest
index 6763bd25a858..3df61579462b 100644
--- a/dev-python/prometheus_client/Manifest
+++ b/dev-python/prometheus_client/Manifest
@@ -1,3 +1,5 @@
DIST prometheus_client-0.0.21.tar.gz 40859 BLAKE2B 58e7a49e12e4f9c865624de24e51e30d4cee75f2f3afd446aa53d425a9aa9ac20829c043ab29036e4e24ef90e06f5950616745ee8f8d89de20e8b1b01d63579f SHA512 e948ecc9044bd6a59fdc58bb3dd638c89d210a5856a360b4270eff206b2280ef7a68c1e94aea64f5cfb68a218499e61627e34c71363ff222b1a3d27403396a31
+DIST prometheus_client-0.1.1.tar.gz 41513 BLAKE2B 3816b34a809c8e40da6fab221bf020bd3d4169c6d1e96a4c48631133cff4fc2839bf1ee01df67711ed4d8c4a38b6ad53c612cddbbb9a7fe45a9b3887cce900e2 SHA512 ac343f416dc4f9907e4da0de19d2005375102fb552491025d76466dee1fb1be753a8e20380c83276116a1606a32a9373db53e8a2952669d511255438d74ba217
EBUILD prometheus_client-0.0.21.ebuild 727 BLAKE2B e934c2ef753903e5ae65c26c38afc3b409119d61d41d2df2379ddbf1d118cd386f9acf9ecfdd8d9078c3a8b644dce7f50f65a05bf9fe6982ed2e72928dcbc90b SHA512 53ed1f26e1213b2959d69ace6094c746eac22ad2446810f068d18b39ef0149f7c59968d0f8a5721e251caf10da86172f83e7b2d8ae39827a7e7a464fbb093788
+EBUILD prometheus_client-0.1.1.ebuild 728 BLAKE2B b42c93f66feff82a028c3d0d77b7bb57b91729a5dafba3b9e116797df407c9105526fe9190ba26dd9cf210a985d761140b2b9b0e2f0e88026ee81c6a5841eefb SHA512 0b5b115423754b9ce74b5f2997ee6a7941d3b9c688179fb276aa0adea29c182e990db536ac6e7de481a17a5123a3e135c445fcc513ba86fc623df3e6c2037658
MISC metadata.xml 451 BLAKE2B 1596b7eb0ca176a5a00d44356c15f35268c3170f90bd13ffaceae39f56511c33f78724ab2cf3748efc1b3b10c71a1d1361ced3192c4c71a6dab5f616fea3051f SHA512 fec61f65143e869244b519455a7214884de5e72c75cf7e500e5aa156c41eb1e644ece46c402cb4722ec294e876078f9332654901b06f2a6f5ab8449f0181532f
diff --git a/dev-python/prometheus_client/prometheus_client-0.1.1.ebuild b/dev-python/prometheus_client/prometheus_client-0.1.1.ebuild
new file mode 100644
index 000000000000..3f109c2efec7
--- /dev/null
+++ b/dev-python/prometheus_client/prometheus_client-0.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="https://pypi.python.org/pypi/prometheus_client"
+SRC_URI="https://github.com/prometheus/client_python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+S=${WORKDIR}/client_python-${PV}
+
+RDEPEND="|| ( dev-python/twisted[${PYTHON_USEDEP}] dev-python/twisted-web[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest || die
+}