summaryrefslogtreecommitdiff
path: root/dev-python/progressbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/progressbar
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/progressbar')
-rw-r--r--dev-python/progressbar/Manifest4
-rw-r--r--dev-python/progressbar/files/progressbar-2.3-python3.3.patch94
-rw-r--r--dev-python/progressbar/metadata.xml11
-rw-r--r--dev-python/progressbar/progressbar-2.3-r3.ebuild21
4 files changed, 130 insertions, 0 deletions
diff --git a/dev-python/progressbar/Manifest b/dev-python/progressbar/Manifest
new file mode 100644
index 000000000000..78607073e100
--- /dev/null
+++ b/dev-python/progressbar/Manifest
@@ -0,0 +1,4 @@
+AUX progressbar-2.3-python3.3.patch 2646 BLAKE2B f381950997463c466fd65b9bf9b3155e67172488cbc436c13e6a64744e92aa41d5c7b592ce9a3028ef066c9cdce886f1736a573ca4f4d8bb5176f6327d79eae2 SHA512 8f6816119c01809f3116ade0d52188cffa86e59fec516343937e6a624fc077dd75906325a88f514568b0e61d262435bf9c743807df2a4099991e8e3bec804b50
+DIST progressbar-2.3.tar.gz 9420 BLAKE2B 025f2d42fb0ef11a2e4b974ba6a8cd44c48a7f828ec40a08347492d393acac46fa9c29962d39fe296af655e94ab2075885c73ed6953e2d739aeb6f5f0c0aa13f SHA512 06fdc8b6664642bd864be8023355316fba23bcc4deb0c5877c5dfa91da5d233301a8f39342f133cbb63f37a20de7b8b24910ac8073127fcbdf43b5200d60ed5f
+EBUILD progressbar-2.3-r3.ebuild 565 BLAKE2B 2c46a6fca71b2cfd62568bfd2454746b8c30e191309520168192415519e3b69be79e21d94c6835e3877d86345b4f25699f6452be4bf5d3e11b49ea93587788e2 SHA512 0b67b7c3a79ae9ea0a8d669cba409edbb0bbd9594b50b4ae1ef0cc5ef9c16ab6cb5f61a122b35b07776e686603dfbc03f554951a881df9079b6992a7285e59c4
+MISC metadata.xml 324 BLAKE2B 28c39259d7567dc383b5f8e80cb81deb5c235fe9431a0a8dc90c7e35a80ff058c541c5f27236db96d5ecbd905071d8ad60a4a6232e31ef99786a0d847f674a39 SHA512 96cd08f27e9f075bacf7c3aa012b69642d245dbf7b99ced6a6cab24c2183c6304cef7bc25a44392319638d20233f9bb6256990f08c6eff60846815de35ed100b
diff --git a/dev-python/progressbar/files/progressbar-2.3-python3.3.patch b/dev-python/progressbar/files/progressbar-2.3-python3.3.patch
new file mode 100644
index 000000000000..112bcf4b3779
--- /dev/null
+++ b/dev-python/progressbar/files/progressbar-2.3-python3.3.patch
@@ -0,0 +1,94 @@
+# HG changeset patch
+# User Nilton Volpato <nilton@google.com>
+# Date 1348267873 10800
+# Fri Sep 21 19:51:13 2012 -0300
+# Node ID 3c94a3a1ebe1325c7c605cc8f11126dcc632b04d
+# Parent 83ece680e4fe06aa704de4c3a967355db21046d4
+Remove format as a slot attribute, as that is not compatible with python 3.3
+
+diff --git a/progressbar/widgets.py b/progressbar/widgets.py
+--- a/progressbar/widgets.py
++++ b/progressbar/widgets.py
+@@ -81,11 +81,11 @@
+ class Timer(Widget):
+ """Widget which displays the elapsed seconds."""
+
+- __slots__ = ('format',)
++ __slots__ = ('format_string',)
+ TIME_SENSITIVE = True
+
+ def __init__(self, format='Elapsed Time: %s'):
+- self.format = format
++ self.format_string = format
+
+ @staticmethod
+ def format_time(seconds):
+@@ -97,7 +97,7 @@
+ def update(self, pbar):
+ """Updates the widget to show the elapsed time."""
+
+- return self.format % self.format_time(pbar.seconds_elapsed)
++ return self.format_string % self.format_time(pbar.seconds_elapsed)
+
+
+ class ETA(Timer):
+@@ -121,9 +121,9 @@
+ class FileTransferSpeed(Widget):
+ """Widget for showing the transfer speed (useful for file transfers)."""
+
+- format = '%6.2f %s%s/s'
+- prefixes = ' kMGTPEZY'
+- __slots__ = ('unit', 'format')
++ FORMAT = '%6.2f %s%s/s'
++ PREFIXES = ' kMGTPEZY'
++ __slots__ = ('unit',)
+
+ def __init__(self, unit='B'):
+ self.unit = unit
+@@ -138,7 +138,7 @@
+ power = int(math.log(speed, 1000))
+ scaled = speed / 1000.**power
+
+- return self.format % (scaled, self.prefixes[power], self.unit)
++ return self.FORMAT % (scaled, self.PREFIXES[power], self.unit)
+
+
+ class AnimatedMarker(Widget):
+@@ -168,13 +168,13 @@
+ class Counter(Widget):
+ """Displays the current count."""
+
+- __slots__ = ('format',)
++ __slots__ = ('format_string',)
+
+ def __init__(self, format='%d'):
+- self.format = format
++ self.format_string = format
+
+ def update(self, pbar):
+- return self.format % pbar.currval
++ return self.format_string % pbar.currval
+
+
+ class Percentage(Widget):
+@@ -197,9 +197,9 @@
+ 'value': ('currval', None)
+ }
+
+- __slots__ = ('format',)
++ __slots__ = ('format_string',)
+ def __init__(self, format):
+- self.format = format
++ self.format_string = format
+
+ def update(self, pbar):
+ context = {}
+@@ -213,7 +213,7 @@
+ context[name] = transform(value)
+ except: pass
+
+- return self.format % context
++ return self.format_string % context
+
+
+ class SimpleProgress(Widget):
diff --git a/dev-python/progressbar/metadata.xml b/dev-python/progressbar/metadata.xml
new file mode 100644
index 000000000000..6ddc4ee3c402
--- /dev/null
+++ b/dev-python/progressbar/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">progressbar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/progressbar/progressbar-2.3-r3.ebuild b/dev-python/progressbar/progressbar-2.3-r3.ebuild
new file mode 100644
index 000000000000..0ed9a3ba1c95
--- /dev/null
+++ b/dev-python/progressbar/progressbar-2.3-r3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Text progressbar library for python"
+HOMEPAGE="https://pypi.org/project/progressbar/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 BSD )"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/progressbar-2.3-python3.3.patch" )