summaryrefslogtreecommitdiff
path: root/dev-python/process-tests/process-tests-2.1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/process-tests/process-tests-2.1.2-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/process-tests/process-tests-2.1.2-r1.ebuild')
-rw-r--r--dev-python/process-tests/process-tests-2.1.2-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/process-tests/process-tests-2.1.2-r1.ebuild b/dev-python/process-tests/process-tests-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..8c972224244e
--- /dev/null
+++ b/dev-python/process-tests/process-tests-2.1.2-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools for testing processes"
+HOMEPAGE="https://github.com/ionelmc/python-process-tests https://pypi.org/project/process-tests/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+# There are no tests at all, under TODO
+# tests/test_process_tests.py is just empty
+RESTRICT="test"
+
+DOCS=( README.rst )