summaryrefslogtreecommitdiff
path: root/dev-python/priority
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/priority
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/priority')
-rw-r--r--dev-python/priority/Manifest3
-rw-r--r--dev-python/priority/files/priority-1.3.0-test-timeout.patch20
-rw-r--r--dev-python/priority/priority-1.3.0.ebuild18
3 files changed, 29 insertions, 12 deletions
diff --git a/dev-python/priority/Manifest b/dev-python/priority/Manifest
index a868e693e983..6a41ef7877e0 100644
--- a/dev-python/priority/Manifest
+++ b/dev-python/priority/Manifest
@@ -1,3 +1,4 @@
+AUX priority-1.3.0-test-timeout.patch 716 BLAKE2B b48691b508a4116c9656acaa3a31871e5c8a66c45d6724506590c95e09eac027969def8198c5bdaa14e50cd77ea105881b7ddb7f36c95665502799f5ea751b6d SHA512 9e809600bc972baf4e1f5366c65db5e5d050bcfd0df23da3d1f75f653a0fdc27f7e4a59e96e13bd42636360653dfdc1de1991e6684e95bfffbf0c4384d7dc550
DIST priority-1.3.0.tar.gz 13827 BLAKE2B 8c100eb44ed42f4f624bfb37dd6f698a3da84812783bd44ba82afef565562379a7677b3cbc9e16c4ea5a5dcc91d0897fa47c341a81bc1875461a72aff328fcff SHA512 cefb13b15e99ef98c37fdd1486466c9e1d7d04b4574cbca1665fde7b7b44cc7d66964bed41184315a9b51bd6f9d0e02bbe113bfa004a754ac270170309b71e0a
-EBUILD priority-1.3.0.ebuild 797 BLAKE2B 5550570403e89eed27566b5d7432acfcfabe4aea33f6d8859dca9a2452fdbf7ea4556449bb078e396cfc3edbdbc43cf9bfb844b44cc6c2646ac4f430e1417820 SHA512 c4681e24537e65ecac96d10db0cb0f5c5645caa86f215d75f7f71479bd9b43115b04bdbd327fd86c003209336f87f63b75b4aabdb192b577329878fdf860bc7f
+EBUILD priority-1.3.0.ebuild 748 BLAKE2B 1cc7d67a4878ffd8f3f3458d6a15aadd6656a9c2285978bf2e19e40d3b32069d1c5821daf94421e97bf267fa774394ed89dc9712209b31147f48a82594397dde SHA512 aa1eab5adff64094c5fa86ab0c7d8c748be02c7e26e72f45c39bd1d67c1bc9ccc6a5c4ae3e37e6e56496157ae602c1bc85244c661b979a030d35c5a27108a7d8
MISC metadata.xml 839 BLAKE2B 2a922ade07ccabbde2eaaeaac310e1c89206f7a6194ea14cd83f53182270edfd2cca4b1d13072d8a4c81c96563ba3b81251626eb777ced188bc9a22a37dcbffb SHA512 fbd62fe6b97e29566a18a29d155b8b08124d5c1561a21ad7aef7daac1a68b75b48b82d3edc612a27888da0d24ecde73b808cb90dfb7fe78ee97adc5fb507b003
diff --git a/dev-python/priority/files/priority-1.3.0-test-timeout.patch b/dev-python/priority/files/priority-1.3.0-test-timeout.patch
new file mode 100644
index 000000000000..3b904f340998
--- /dev/null
+++ b/dev-python/priority/files/priority-1.3.0-test-timeout.patch
@@ -0,0 +1,20 @@
+diff -dupr a/test/test_priority.py b/test/test_priority.py
+--- a/test/test_priority.py 2017-01-27 11:57:03.000000000 +0100
++++ b/test/test_priority.py 2019-11-22 09:03:52.772710452 +0100
+@@ -12,7 +12,7 @@ import itertools
+
+ import pytest
+
+-from hypothesis import given
++from hypothesis import given, settings
+ from hypothesis.strategies import (
+ integers, lists, tuples, sampled_from
+ )
+@@ -489,6 +489,7 @@ class TestPriorityTreeOutput(object):
+ fairness and equidistribution.
+ """
+ @given(STREAMS_AND_WEIGHTS)
++ @settings(deadline=None)
+ def test_period_of_repetition(self, streams_and_weights):
+ """
+ The period of repetition of a priority sequence is given by the sum of
diff --git a/dev-python/priority/priority-1.3.0.ebuild b/dev-python/priority/priority-1.3.0.ebuild
index 7ce73432ed63..fc22a3fbb745 100644
--- a/dev-python/priority/priority-1.3.0.ebuild
+++ b/dev-python/priority/priority-1.3.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy)
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy)
inherit distutils-r1
@@ -15,18 +15,14 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86"
-IUSE="test"
-
-RDEPEND=""
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
- )
+ test? ( >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}] )
"
-python_test() {
- py.test -vv || die "Tests failed under ${EPYTHON}"
-}
+PATCHES=(
+ "${FILESDIR}"/priority-1.3.0-test-timeout.patch
+)
+
+distutils_enable_tests pytest