summaryrefslogtreecommitdiff
path: root/dev-python/prettytable
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/prettytable
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest5
-rw-r--r--dev-python/prettytable/metadata.xml12
-rw-r--r--dev-python/prettytable/prettytable-0.7.1-r1.ebuild24
-rw-r--r--dev-python/prettytable/prettytable-0.7.2.ebuild24
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
new file mode 100644
index 000000000000..f18719aa29da
--- /dev/null
+++ b/dev-python/prettytable/Manifest
@@ -0,0 +1,5 @@
+DIST prettytable-0.7.1.tar.bz2 21499 BLAKE2B 6f8e3306fd26e134dbcfed18cbb641f6b167cc9b91846fd14ee9402c5f7384d71b00d120dfe32cc6948ff6cf78c613c8f4317cae0ae5b3eb028e16f1054cac12 SHA512 1a7aa604f608483b107401ddca9721ddea673ea1415d2a514948f7399835784e0a9025f0e5236f4109890e5924da345bd111893200730501b496c136465c204f
+DIST prettytable-0.7.2.tar.bz2 21755 BLAKE2B 385d5bd6d4ab75a8c7ae96abc9d9e98a66a196265853113e7fb59073876e9f5e9c6c4fba9a30d80cc726a5184e78fb6451ff9a553909704fcc5022b6a08413f4 SHA512 f3a3fe6fa29f4ef090ff6cac06549ebd9db8b387e7b25fc64c4e37c8444586f50355c5573f38caabc72360aa68054aa189a67aa37f0bd13b872862ecd9151e71
+EBUILD prettytable-0.7.1-r1.ebuild 599 BLAKE2B 731536aa4482096159be2569e00a84c4cd7d8dd397be02272fcf2026c98cc8316556041831ccf8c077e06338d4119c81cc67711c7fbe934fa0114b58cf3f9dc8 SHA512 4759b8ee7210fc0c0acd409e9298b3fcd4494bbad8407b7c786ab63f2c325dc32b452b9d053064664d5d9afedf74f8799a431985659f2286dfd8abc569813f4a
+EBUILD prettytable-0.7.2.ebuild 618 BLAKE2B 754ffa898213b885afd7bc7a8d1633e0fc5b610af1800c7e5bfd2c553161bf4c4dc03ba80d49a10fbe863553b840d3530ded8c2d43690f081a7d25babd7a6fa8 SHA512 aa01e2fbeadc546dd3435896f0e938eab2538288c54cb07c39cedbb1fbd5016e81e02d028a6969f22b12204c41aaf2b21b0c9004031577da13a85222cbbdf0d7
+MISC metadata.xml 388 BLAKE2B c19229c631dbaafafe2f8b2bcb0650052b4827bd6d0901d51d7c16fcf2456fca33efbcd21ee3ea1012a1b28c7cfc67042661b02bcc23af6d5768bf180304efd5 SHA512 7ac1cfd03216f171bf432f35b21bd6b43d297e77f41dffe5c5c5c4d85614c799252182a06bd5a116b5b831c06df115dcb933f1b2fd051eca8676f0aca7997d58
diff --git a/dev-python/prettytable/metadata.xml b/dev-python/prettytable/metadata.xml
new file mode 100644
index 000000000000..4a76f215cc7a
--- /dev/null
+++ b/dev-python/prettytable/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">prettytable</remote-id>
+ <remote-id type="pypi">PrettyTable</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/prettytable/prettytable-0.7.1-r1.ebuild b/dev-python/prettytable/prettytable-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..8d56cb958571
--- /dev/null
+++ b/dev-python/prettytable/prettytable-0.7.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="https://code.google.com/p/prettytable/"
+SRC_URI="mirror://pypi/P/PrettyTable/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" prettytable_test.py || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/prettytable/prettytable-0.7.2.ebuild b/dev-python/prettytable/prettytable-0.7.2.ebuild
new file mode 100644
index 000000000000..d80f4b999a5f
--- /dev/null
+++ b/dev-python/prettytable/prettytable-0.7.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="https://code.google.com/p/prettytable/"
+SRC_URI="mirror://pypi/P/PrettyTable/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" prettytable_test.py || die "tests failed under ${EPYTHON}"
+}