summaryrefslogtreecommitdiff
path: root/dev-python/prettytable
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-python/prettytable
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest1
-rw-r--r--dev-python/prettytable/prettytable-0.7.2-r1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index f85f7d2b9901..d74d42e40888 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,5 +1,6 @@
DIST prettytable-0.7.1.tar.bz2 21499 BLAKE2B 6f8e3306fd26e134dbcfed18cbb641f6b167cc9b91846fd14ee9402c5f7384d71b00d120dfe32cc6948ff6cf78c613c8f4317cae0ae5b3eb028e16f1054cac12 SHA512 1a7aa604f608483b107401ddca9721ddea673ea1415d2a514948f7399835784e0a9025f0e5236f4109890e5924da345bd111893200730501b496c136465c204f
DIST prettytable-0.7.2.tar.bz2 21755 BLAKE2B 385d5bd6d4ab75a8c7ae96abc9d9e98a66a196265853113e7fb59073876e9f5e9c6c4fba9a30d80cc726a5184e78fb6451ff9a553909704fcc5022b6a08413f4 SHA512 f3a3fe6fa29f4ef090ff6cac06549ebd9db8b387e7b25fc64c4e37c8444586f50355c5573f38caabc72360aa68054aa189a67aa37f0bd13b872862ecd9151e71
EBUILD prettytable-0.7.1-r1.ebuild 599 BLAKE2B 731536aa4482096159be2569e00a84c4cd7d8dd397be02272fcf2026c98cc8316556041831ccf8c077e06338d4119c81cc67711c7fbe934fa0114b58cf3f9dc8 SHA512 4759b8ee7210fc0c0acd409e9298b3fcd4494bbad8407b7c786ab63f2c325dc32b452b9d053064664d5d9afedf74f8799a431985659f2286dfd8abc569813f4a
+EBUILD prettytable-0.7.2-r1.ebuild 620 BLAKE2B 0a604b1cd0b65d72d7eaf3115f6f8018a78bd518e0b70feea6906cffb0fe6df2757bfd0813dba9b4bc2554412d2835d14a22f76bc60e96c69271fd340123f6db SHA512 f4eed0dfac7d3b39676ca4839982cdaacbd45c0f7cd7b5cb6114cd67590c67c8b155e9ef355a710730f32b6cfa88e469001e7e7caf3a8da45945975e1478a60c
EBUILD prettytable-0.7.2.ebuild 617 BLAKE2B 7400886ab5f73f1058a0ad4d93899dbbc3d1078cae3a82f4a89eaeab762a0167125da86ca3a54768a7b5e72ce7aaba8fdadcdb22aa1bdc5515334895ce3d761b SHA512 d47a152c7d9fc940ced485efbbfc361d7f4085b959f2f01a155a1633d948624df4ab656a2bb69483366db27db2bfe4c6ab641a7567c102f0933dcd820eea2b0f
MISC metadata.xml 388 BLAKE2B c19229c631dbaafafe2f8b2bcb0650052b4827bd6d0901d51d7c16fcf2456fca33efbcd21ee3ea1012a1b28c7cfc67042661b02bcc23af6d5768bf180304efd5 SHA512 7ac1cfd03216f171bf432f35b21bd6b43d297e77f41dffe5c5c5c4d85614c799252182a06bd5a116b5b831c06df115dcb933f1b2fd051eca8676f0aca7997d58
diff --git a/dev-python/prettytable/prettytable-0.7.2-r1.ebuild b/dev-python/prettytable/prettytable-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..ab4c1ba7e987
--- /dev/null
+++ b/dev-python/prettytable/prettytable-0.7.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="https://code.google.com/p/prettytable/"
+SRC_URI="mirror://pypi/P/PrettyTable/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" prettytable_test.py || die "tests failed under ${EPYTHON}"
+}