summaryrefslogtreecommitdiff
path: root/dev-python/prettytable/prettytable-3.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-12 14:20:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-12 14:20:03 +0100
commit522b6bf7e1f6133c288b94a77fc5e3d8eef2c179 (patch)
treec6624f4b91276a0312ca31ebfa276732608dddba /dev-python/prettytable/prettytable-3.8.0.ebuild
parent4d0ca679fbcb59301ffc7af98794c411c5061a0b (diff)
gentoo auto-resync : 12:06:2023 - 14:20:02
Diffstat (limited to 'dev-python/prettytable/prettytable-3.8.0.ebuild')
-rw-r--r--dev-python/prettytable/prettytable-3.8.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/prettytable/prettytable-3.8.0.ebuild b/dev-python/prettytable/prettytable-3.8.0.ebuild
new file mode 100644
index 000000000000..e7e226037a5e
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest