summaryrefslogtreecommitdiff
path: root/dev-python/pretend
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pretend
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pretend')
-rw-r--r--dev-python/pretend/Manifest3
-rw-r--r--dev-python/pretend/pretend-1.0.9-r1.ebuild4
-rw-r--r--dev-python/pretend/pretend-1.0.9-r2.ebuild25
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-python/pretend/Manifest b/dev-python/pretend/Manifest
index 0a157a8690de..596a3a3bcacd 100644
--- a/dev-python/pretend/Manifest
+++ b/dev-python/pretend/Manifest
@@ -1,3 +1,4 @@
DIST pretend-1.0.9.tar.gz 5656 BLAKE2B 1a8e280fbbf147f502f1148b9e3685630e0f5cd270dc8b6fa8fbbd8177aaa08efe401a6684b669a976d828e7fcdd48d686170bfa3cd3d8a857b78af473a5b6f8 SHA512 976e3272557aecfb11e4147a868ea96e23546e277d57d726f41b945103bef3451039716e6bbc5082d691fa1fd331c06b3d0f8b254deb0510948153571326eaf0
-EBUILD pretend-1.0.9-r1.ebuild 629 BLAKE2B 85c8c4f23a528e29301d84a0565bb8a95a6011bc63c01fcef3d46f840835109586579287bfc62b99fadd2a01bd09348f557ae19061b005842173a2bcc151871b SHA512 0502ae0b5fe619243238ace653537e41228bd3bb8d0865abde8df0c5c9c029da4274f952830ab3cddcc1ab8c705bfacd7043cf60ccfada5949740d276479fb3e
+EBUILD pretend-1.0.9-r1.ebuild 636 BLAKE2B 46173e947d7c83dd35745007016b2edf123a8de305745bd5ef0f8d910672e46aa510bb20e6ebaabb1df99235e1e647f73065b4929e95eaf938a91a640f7dfb6b SHA512 9275e1301cad1f97b396ecf89713bbbbb6915f9b9d9f2ced92c1864084c8f904fea6c2d65d1874010089f08691c927dc4a198708fb3a9b2a9cb8fd17db844edb
+EBUILD pretend-1.0.9-r2.ebuild 685 BLAKE2B a22a1769a4b818272c341775e65835250844d85f3cfa56e50d4761113dd417ac4ce3327add9cad18304ff826739c9f3e2abdcbf8c956f180aeab0578115c720f SHA512 7a1fa4a3c6f3f03de6e526d53459b20f3c29eac691625dbfffece01815e83a233c3953b8d1df6257d75e7f5da1cca6db1425f56a24c0d48833843f0f0729804f
MISC metadata.xml 400 BLAKE2B a021fe05403ac78ec9e777a5214a66db753eed4dc98fc912102a6f58993fe507455ff7666f0f2d0b3bc8e035ec94def5f2562dc0565444b938723c21c1462cfc SHA512 982fd46410dead08959a8595503b24fa23eb3bf6e1f6ef3ba34845e0345fb42a7631794bc2906cb8a68c56b16cc49cdec84aeb5c7b348713731fa9812d694960
diff --git a/dev-python/pretend/pretend-1.0.9-r1.ebuild b/dev-python/pretend/pretend-1.0.9-r1.ebuild
index e946afbb9bed..07d771c34f88 100644
--- a/dev-python/pretend/pretend-1.0.9-r1.ebuild
+++ b/dev-python/pretend/pretend-1.0.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,6 +13,6 @@ SRC_URI="https://github.com/alex/pretend/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
distutils_enable_tests pytest
diff --git a/dev-python/pretend/pretend-1.0.9-r2.ebuild b/dev-python/pretend/pretend-1.0.9-r2.ebuild
new file mode 100644
index 000000000000..ab44f3afaa3d
--- /dev/null
+++ b/dev-python/pretend/pretend-1.0.9-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for stubbing in Python"
+HOMEPAGE="
+ https://github.com/alex/pretend/
+ https://pypi.org/project/pretend/
+"
+SRC_URI="
+ https://github.com/alex/pretend/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests pytest