summaryrefslogtreecommitdiff
path: root/dev-python/polib/polib-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-24 09:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-24 09:47:15 +0000
commit4003c614d3c4b320c45ab1f4b817459d4709443b (patch)
treefcc0c42e92c56abe0ea39b717b2c3b019c335e41 /dev-python/polib/polib-1.2.0.ebuild
parent58177544118b9a8393d7501ee5e0e35cd32f2ad4 (diff)
gentoo auto-resync : 24:02:2023 - 09:47:15
Diffstat (limited to 'dev-python/polib/polib-1.2.0.ebuild')
-rw-r--r--dev-python/polib/polib-1.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/polib/polib-1.2.0.ebuild b/dev-python/polib/polib-1.2.0.ebuild
new file mode 100644
index 000000000000..1bc25e6957ea
--- /dev/null
+++ b/dev-python/polib/polib-1.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A library to manipulate gettext files (.po and .mo files)"
+HOMEPAGE="
+ https://github.com/izimobil/polib/
+ https://pypi.org/project/polib/
+ https://polib.readthedocs.io/en/latest/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_sphinx docs
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.7-BE-test.patch
+)
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die "Tests failed under ${EPYTHON}"
+}