summaryrefslogtreecommitdiff
path: root/dev-python/poetry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-22 20:51:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-22 20:51:36 +0100
commitdb80e2ef5b5a94d879a855799e86467f62293531 (patch)
treea08e6a23fe79165da2eeefacec6038382c1f89ff /dev-python/poetry
parent5772eab78c27d5409ea9e818a12abc9f686e7319 (diff)
gentoo auto-resync : 22:07:2023 - 20:51:35
Diffstat (limited to 'dev-python/poetry')
-rw-r--r--dev-python/poetry/Manifest3
-rw-r--r--dev-python/poetry/metadata.xml16
-rw-r--r--dev-python/poetry/poetry-1.5.1.ebuild92
3 files changed, 111 insertions, 0 deletions
diff --git a/dev-python/poetry/Manifest b/dev-python/poetry/Manifest
new file mode 100644
index 000000000000..bf581597b74d
--- /dev/null
+++ b/dev-python/poetry/Manifest
@@ -0,0 +1,3 @@
+DIST poetry-1.5.1.tar.gz 1469755 BLAKE2B ac60d6aabe69b1e46a6fbc188579034e716a470384571a611952489d175485cf997636c9206a53e29be073582e672f8010ab5f8f13b58a12dc644279753f903e SHA512 863bc4ea43b6fc5b340f50f007c76d2c253223d6bd55ea5c1ead4bc353c3d4cd85d51372a774276e14d9fca733fac9c2f582892fec950b74f25dc188dafa7a96
+EBUILD poetry-1.5.1.ebuild 3928 BLAKE2B 961203605de46d649decc8dbec26b8ee52571cd569ab0d383f6b371f38897059ec7f20c89d919586e15c8157d0a9c3b29679efe87a05efaadb9b5f404e8dbeec SHA512 d2813f9ba955a8f3d1867b1f2b61cd470706684740fe34ca3b6636a5d02239d2e16c6ca5ee5baf7b417e64054b09974b18c8540557049559ad7a1137cd920664
+MISC metadata.xml 486 BLAKE2B 7757afe2f964f49a04a600ec80af8511387c3a80105c9050755e1815cac148734f540e4da8c1da401c15a63bf5d0a8200ed6a5e1c09e5dacc7d39f5f59dd343f SHA512 541063e55b4dc5b927ef4ff6b385663bbf978d13ac6644c2537483ec42f211780cab4d881b159894dfe86519b4655c80bcfe17cdb90a2e033077b390a3842f46
diff --git a/dev-python/poetry/metadata.xml b/dev-python/poetry/metadata.xml
new file mode 100644
index 000000000000..a87ee8e5007b
--- /dev/null
+++ b/dev-python/poetry/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>martin-kokos@protonmail.com</email>
+ <name>Martin Mokry</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">poetry</remote-id>
+ <remote-id type="github">python-poetry/poetry</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/poetry/poetry-1.5.1.ebuild b/dev-python/poetry/poetry-1.5.1.ebuild
new file mode 100644
index 000000000000..9fa3a6a19ab3
--- /dev/null
+++ b/dev-python/poetry/poetry-1.5.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A frontend for poetry - a python dependency management and packaging tool"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry
+ https://pypi.org/project/poetry/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/poetry-core-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/poetry-plugin-export-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/build-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/cleo-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/crashtest-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.21.2[${PYTHON_USEDEP}]
+ >=dev-python/installer-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.10.0[${PYTHON_USEDEP}]
+ >=dev-python/keyring-23.9.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+ >=dev-python/pexpect-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/shellingham-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
+ >=dev-python/trove-classifiers-2022.5.19[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.22.0[${PYTHON_USEDEP}]
+ >=dev-python/cachecontrol-0.12.9[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ >=dev-python/deepdiff-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # Dependency on abandoned package cachy has been removed from poetry https://github.com/python-poetry/poetry/pull/5868
+ # and remains in tests only for time being, so we can skip them.
+ # removal of tests upstream https://github.com/python-poetry/poetry/pull/7437
+ sed -e "s/from cachy import CacheManager/from unittest import mock; CacheManager = mock.Mock # Gentoo ebuild patched/g" \
+ -i tests/console/commands/cache/conftest.py \
+ -i tests/utils/test_cache.py || die
+ sed -e 's:"cachy_file_cache", ::g' \
+ -i tests/utils/test_cache.py || die
+
+ distutils-r1_src_prepare
+}
+
+EPYTEST_DESELECT=(
+ # Dependency on abandoned package cachy has been removed from poetry https://github.com/python-poetry/poetry/pull/5868
+ # and remains in tests only for time being, so we can skip them.
+ # removal of tests upstream https://github.com/python-poetry/poetry/pull/7437
+ tests/console/commands/cache/test_clear.py::test_cache_clear_all
+ tests/console/commands/cache/test_clear.py::test_cache_clear_all_no
+ tests/console/commands/cache/test_clear.py::test_cache_clear_pkg
+ tests/console/commands/cache/test_clear.py::test_cache_clear_pkg_no
+ tests/utils/test_cache.py::test_cachy_compatibility
+
+ # Tests require network (they run `pip install ...`)
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_directories
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_git
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_git_with_subdirectories
+ tests/installation/test_pip_installer.py::test_uninstall_git_package_nspkg_pth_cleanup
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_non_wheel_files
+ tests/installation/test_installer.py::test_installer_with_pypi_repository
+
+ # Works with network, but otherwise: Backend 'poetry.core.masonry.api' is not available.
+ tests/installation/test_chef.py::test_prepare_sdist
+ tests/installation/test_chef.py::test_prepare_directory
+ tests/installation/test_chef.py::test_prepare_directory_with_extensions
+ tests/installation/test_chef.py::test_prepare_directory_editable
+)
+
+distutils_enable_tests pytest