summaryrefslogtreecommitdiff
path: root/dev-python/poetry-plugin-export
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-22 20:51:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-22 20:51:36 +0100
commitdb80e2ef5b5a94d879a855799e86467f62293531 (patch)
treea08e6a23fe79165da2eeefacec6038382c1f89ff /dev-python/poetry-plugin-export
parent5772eab78c27d5409ea9e818a12abc9f686e7319 (diff)
gentoo auto-resync : 22:07:2023 - 20:51:35
Diffstat (limited to 'dev-python/poetry-plugin-export')
-rw-r--r--dev-python/poetry-plugin-export/Manifest3
-rw-r--r--dev-python/poetry-plugin-export/metadata.xml16
-rw-r--r--dev-python/poetry-plugin-export/poetry-plugin-export-1.4.0.ebuild33
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/poetry-plugin-export/Manifest b/dev-python/poetry-plugin-export/Manifest
new file mode 100644
index 000000000000..9d5b8d080c0f
--- /dev/null
+++ b/dev-python/poetry-plugin-export/Manifest
@@ -0,0 +1,3 @@
+DIST poetry_plugin_export-1.4.0.tar.gz 28553 BLAKE2B d2f7de4da9975cefde9ac02d9e4a36eada89fe00926eaf58d8ea402d57ef53209aa2e564b46616f0d71fa675512de6335a33a1714efe4a696f05c909a8313e45 SHA512 60fd1a63505e82f62372e7ec4e4908835f0556e86213b58ce836d3cf64bd6de8f83cbc965ad1a2b59c50ca3bf287675bda46b5a410a5f65078e091004eaf8ed9
+EBUILD poetry-plugin-export-1.4.0.ebuild 723 BLAKE2B a66933cde927d9b3c2d78ce66a9ae9ae4104ab84a8d3057dc878016d1b3bb3126f77fdfca9e40b25838d5931cdbaf403d3b5731b3c0820f2b87a86e1e9f715a8 SHA512 796eb177b651fceb18984d6b4a2945e0828f5180c508a75ff717c4ad69aeb772ba3385b62f2dfbc99e60d8881c17bc329e0c7cc931a4d7321f2e89df345c42a4
+MISC metadata.xml 514 BLAKE2B 27e1402c90d372d44302449b8b826a66a9795227e72a6b30ccdc316ff0146bb011b8a9fca613e8675ebe13c360d4ba77b6b30a057981e552e3f5762c3af6e65b SHA512 b214726af4d39d3f9a082d4e09e88d1fc63541f18cbdc31e9ceac88aa01ff44eb52cfbfdcca0994f5fd86b905ebbf39af2b0d083f7bca085c1a52c6cab52b630
diff --git a/dev-python/poetry-plugin-export/metadata.xml b/dev-python/poetry-plugin-export/metadata.xml
new file mode 100644
index 000000000000..20f252723c38
--- /dev/null
+++ b/dev-python/poetry-plugin-export/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>martin-kokos@protonmail.com</email>
+ <name>Martin Mokry</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">poetry-plugin-export</remote-id>
+ <remote-id type="github">python-poetry/poetry-plugin-export</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/poetry-plugin-export/poetry-plugin-export-1.4.0.ebuild b/dev-python/poetry-plugin-export/poetry-plugin-export-1.4.0.ebuild
new file mode 100644
index 000000000000..b69f11168144
--- /dev/null
+++ b/dev-python/poetry-plugin-export/poetry-plugin-export-1.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A plugin that allows the export of locked packages to various formats"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry-plugin-export
+ https://pypi.org/project/poetry-plugin-export/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/poetry-core-1.6.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/poetry[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest