summaryrefslogtreecommitdiff
path: root/dev-python/pocketlint/pocketlint-0.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-14 13:40:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-14 13:40:00 +0100
commit3e627c1432765cb6a32877e73f985e8bfb5102ce (patch)
treee4d7919d9e1ca0a54c1a3758c86555d6e9121956 /dev-python/pocketlint/pocketlint-0.24.ebuild
parent4a30f472147c2d8642bd558b78fcfce7b6a9c6b9 (diff)
gentoo auto-resync : 14:07:2022 - 13:40:00
Diffstat (limited to 'dev-python/pocketlint/pocketlint-0.24.ebuild')
-rw-r--r--dev-python/pocketlint/pocketlint-0.24.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pocketlint/pocketlint-0.24.ebuild b/dev-python/pocketlint/pocketlint-0.24.ebuild
new file mode 100644
index 000000000000..c6c11e93d7a8
--- /dev/null
+++ b/dev-python/pocketlint/pocketlint-0.24.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Shared code for running pylint against rhinstaller projects"
+HOMEPAGE="
+ https://github.com/rhinstaller/pocketlint/
+ https://pypi.org/project/pocketlint/
+"
+SRC_URI="
+ https://github.com/rhinstaller/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+"