summaryrefslogtreecommitdiff
path: root/dev-python/ply/ply-3.11-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/ply/ply-3.11-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/ply/ply-3.11-r1.ebuild')
-rw-r--r--dev-python/ply/ply-3.11-r1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/ply/ply-3.11-r1.ebuild b/dev-python/ply/ply-3.11-r1.ebuild
deleted file mode 100644
index b196fb5a852a..000000000000
--- a/dev-python/ply/ply-3.11-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python Lex-Yacc library"
-HOMEPAGE="http://www.dabeaz.com/ply/ https://pypi.org/project/ply/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples"
-
-DOCS=( ANNOUNCE CHANGES TODO )
-
-PATCHES=( "${FILESDIR}/3.6-picklefile-IOError.patch" )
-
-python_test() {
- cp -r -l test "${BUILD_DIR}"/ || die
- cd "${BUILD_DIR}"/test || die
-
- # Checks for pyc/pyo files
- local -x PYTHONDONTWRITEBYTECODE=
-
- local t
- for t in testlex.py testyacc.py; do
- "${EPYTHON}" "${t}" -v || die "${t} fails with ${EPYTHON}"
- done
-}
-
-python_install_all() {
- local HTML_DOCS=( doc/. )
- use examples && dodoc -r example
- distutils-r1_python_install_all
-}