summaryrefslogtreecommitdiff
path: root/dev-python/plumbum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-01 00:00:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-01 00:00:05 +0100
commit3d12b65aa1b4bb8b02b1f8d3e77bccf230b79a09 (patch)
treecb6347688c91bfbdebe49a78a55dad3d72cc193e /dev-python/plumbum
parent4c2b70adc6484c35ff05e412de08a7b7f50cfb34 (diff)
gentoo auto-resync : 01:05:2024 - 00:00:04
Diffstat (limited to 'dev-python/plumbum')
-rw-r--r--dev-python/plumbum/Manifest2
-rw-r--r--dev-python/plumbum/plumbum-1.8.3.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/plumbum/Manifest b/dev-python/plumbum/Manifest
index 775e0bd2b8f1..9b3ec802fa75 100644
--- a/dev-python/plumbum/Manifest
+++ b/dev-python/plumbum/Manifest
@@ -1,3 +1,5 @@
DIST plumbum-1.8.2.tar.gz 317675 BLAKE2B d21a105d9919f70ad480d5de7ce157f2ae6c56cd248a2b70ad037c83a5e4b56bd8bdb3d9587860db383b04dd6528828426b47895c345f8bf7dc4931310be343d SHA512 636d10ea1c727cb24d4692537f3c0005077f86c3d9d2ae244f86ef5dd9621f8b51e0b5efffaa7acf66d6ba5552fddd641d4a1796c7fd760ac0a27d029f685c20
+DIST plumbum-1.8.3.tar.gz 318895 BLAKE2B 7c3df70e5bcaf5dfd9c6898f0d2044c647f08a4eaa0eb6bcb616c9971edfc20aa7651dc70a193e06c1d1f97b155a86a6d93d14622ff40da1328b1aa0e6534e6b SHA512 e59dd98939739636c3f1541e24f3c5a4b0c9bbe54b77d378875a57f167ca1916adbca6b33c7779d37e5daebd949c9a9d77bfffc404e55d319027658b5a504088
EBUILD plumbum-1.8.2.ebuild 1400 BLAKE2B c94b9f038f960edbd3dd85e080fc20db7593025503ee1435e7f3f3462d23a935249d7b1d7f29516a9f9279c7f11ac35aea6b45dbbc04f0a64322fc043f9e517f SHA512 434673b58936c085701c3fde4494a6be9e767a4bc784c2b79c4d2817010beb93c3c15156ddc3f6392b446b69f27bf2dc699e33de954d326c38d3996092711d3a
+EBUILD plumbum-1.8.3.ebuild 1440 BLAKE2B a078422b6ff1b903544763975e2da39403fabdf48b3724de2010fb31bd4ef1f8806f0fd38be7314dde6bb41116e039c3c3f34ee8de65950a65da25f4b6e5b2bc SHA512 c2a04c4bcc9268184384bbee146e1e904d97018897f56c395f8e20b1ebc64b54945b3bae92c7984c7d93a858e0a32488ec467e2e27789f311a32cffd3cfeb113
MISC metadata.xml 754 BLAKE2B b6d00fe0747da15445953a29abdd6f14112d02f2162746992f2fca80a321cd10f3cad40294e4bdbcf3f04d432b4d81902667296a0a5b8f99da2df2a5c58b18c1 SHA512 fbadbb7e5edd1573994cfc843e4a254ae5d12be5a3372f4fb061647983e360c2b0ea4a9e41ea8c9ff26028db75ad9cd5de881b8fdd9bf35864442e215aa42175
diff --git a/dev-python/plumbum/plumbum-1.8.3.ebuild b/dev-python/plumbum/plumbum-1.8.3.ebuild
new file mode 100644
index 000000000000..744229f04666
--- /dev/null
+++ b/dev-python/plumbum/plumbum-1.8.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="A library for shell script-like programs in python"
+HOMEPAGE="
+ https://plumbum.readthedocs.io/en/latest/
+ https://github.com/tomerfiliba/plumbum/
+ https://pypi.org/project/plumbum/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Need sshd running
+ tests/test_remote.py
+ tests/test_utils.py
+ # Windows specific
+ tests/test_putty.py
+ # Needs sudo without password
+ tests/test_sudo.py
+ # Wrong assumptions about env handling
+ tests/test_env.py::TestEnv::test_change_env
+ tests/test_env.py::TestEnv::test_dictlike
+ tests/test_local.py::TestLocalPath::test_iterdir
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p pytest_mock -p timeout
+}
+
+pkg_postinst() {
+ optfeature "remote commands via ssh" dev-python/paramiko
+ optfeature "progress bars in jupyter" dev-python/ipywidgets
+ optfeature "colored output in jupyter" dev-python/ipython
+ optfeature "images on the command line" dev-python/pillow
+}