summaryrefslogtreecommitdiff
path: root/dev-python/plumbum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-31 09:23:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-31 09:23:01 +0100
commit441510fa20665b7920b149994e72b3a1cd62a813 (patch)
tree4bc2e347ca49e5da4915fc3c117c0db31b0ac6cd /dev-python/plumbum
parent3810dd6a469ba3e0014a390d92f1fc220dd20c3b (diff)
gentoo auto-resync : 31:05:2023 - 09:23:01
Diffstat (limited to 'dev-python/plumbum')
-rw-r--r--dev-python/plumbum/Manifest2
-rw-r--r--dev-python/plumbum/plumbum-1.8.2.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/plumbum/Manifest b/dev-python/plumbum/Manifest
index 8890a3b8815a..f4471add4167 100644
--- a/dev-python/plumbum/Manifest
+++ b/dev-python/plumbum/Manifest
@@ -1,3 +1,5 @@
DIST plumbum-1.8.1.tar.gz 316432 BLAKE2B 91288c5f793b9e3e7d1e1d3724f5cc16989d604b1236438fc71283fab5aa59bb34f1742fe2d79b7a9220e09a3622f5145769497765f3f9213dc70960af478fa0 SHA512 80031c07be3b68767556bba8246e964c51b16336d6105ad3d51d62f7c39287af6f928be713171c8c22cdd37145a0e7c3bd65d44f14bf8b1bc62483b648f3acff
+DIST plumbum-1.8.2.tar.gz 317675 BLAKE2B d21a105d9919f70ad480d5de7ce157f2ae6c56cd248a2b70ad037c83a5e4b56bd8bdb3d9587860db383b04dd6528828426b47895c345f8bf7dc4931310be343d SHA512 636d10ea1c727cb24d4692537f3c0005077f86c3d9d2ae244f86ef5dd9621f8b51e0b5efffaa7acf66d6ba5552fddd641d4a1796c7fd760ac0a27d029f685c20
EBUILD plumbum-1.8.1.ebuild 1400 BLAKE2B fc2e99e0c0e0667e9df8873a1872a447ec7e6993ec22fef83214a47eceb9a054d2884610a23de81477ab379f3ff683cd44a66c2cd550ea4038f5e2971d55bbc9 SHA512 8850841d5d7a74527cfe3c1ffb78081313ad5b01cc3f054ed960a68b51b89db129bf7130ffb1ff1bda2f0d78813b8a1ef1cb7d03767f7b0cb93fe7c879f60eda
+EBUILD plumbum-1.8.2.ebuild 1403 BLAKE2B 0243df3a5511ad23e44adb0c8dafbd2d2ea3aa4455331a7ef883759c7dd4c13cf40f4e48d577977e35a6c3517d27b59bb6523909c11a50abf83b971a4de1c1b1 SHA512 da2bb8685ef1adf95cb251f1d76064e648008aa04b8e1dfd60df1151709907c0f651822fae01f8c306a92d15635db307652f1544593a7404fbfc7288789201ae
MISC metadata.xml 754 BLAKE2B b6d00fe0747da15445953a29abdd6f14112d02f2162746992f2fca80a321cd10f3cad40294e4bdbcf3f04d432b4d81902667296a0a5b8f99da2df2a5c58b18c1 SHA512 fbadbb7e5edd1573994cfc843e4a254ae5d12be5a3372f4fb061647983e360c2b0ea4a9e41ea8c9ff26028db75ad9cd5de881b8fdd9bf35864442e215aa42175
diff --git a/dev-python/plumbum/plumbum-1.8.2.ebuild b/dev-python/plumbum/plumbum-1.8.2.ebuild
new file mode 100644
index 000000000000..2ccac16554dd
--- /dev/null
+++ b/dev-python/plumbum/plumbum-1.8.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="A library for shell script-like programs in python"
+HOMEPAGE="
+ https://plumbum.readthedocs.io/en/latest/
+ https://github.com/tomerfiliba/plumbum/
+ https://pypi.org/project/plumbum/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Need sshd running
+ tests/test_remote.py
+ tests/test_utils.py
+ # Windows specific
+ tests/test_putty.py
+ # Needs sudo without password
+ tests/test_sudo.py
+ # Wrong assumptions about env handling
+ tests/test_env.py::TestEnv::test_change_env
+ tests/test_env.py::TestEnv::test_dictlike
+ tests/test_local.py::TestLocalPath::test_iterdir
+)
+
+src_prepare() {
+ sed -e '/addopts/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ optfeature "remote commands via ssh" dev-python/paramiko
+ optfeature "progress bars in jupyter" dev-python/ipywidgets
+ optfeature "colored output in jupyter" dev-python/ipython
+ optfeature "images on the command line" dev-python/pillow
+}