summaryrefslogtreecommitdiff
path: root/dev-python/plumbum/plumbum-1.8.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-01 00:00:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-01 00:00:05 +0100
commit3d12b65aa1b4bb8b02b1f8d3e77bccf230b79a09 (patch)
treecb6347688c91bfbdebe49a78a55dad3d72cc193e /dev-python/plumbum/plumbum-1.8.3.ebuild
parent4c2b70adc6484c35ff05e412de08a7b7f50cfb34 (diff)
gentoo auto-resync : 01:05:2024 - 00:00:04
Diffstat (limited to 'dev-python/plumbum/plumbum-1.8.3.ebuild')
-rw-r--r--dev-python/plumbum/plumbum-1.8.3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/plumbum/plumbum-1.8.3.ebuild b/dev-python/plumbum/plumbum-1.8.3.ebuild
new file mode 100644
index 000000000000..744229f04666
--- /dev/null
+++ b/dev-python/plumbum/plumbum-1.8.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="A library for shell script-like programs in python"
+HOMEPAGE="
+ https://plumbum.readthedocs.io/en/latest/
+ https://github.com/tomerfiliba/plumbum/
+ https://pypi.org/project/plumbum/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Need sshd running
+ tests/test_remote.py
+ tests/test_utils.py
+ # Windows specific
+ tests/test_putty.py
+ # Needs sudo without password
+ tests/test_sudo.py
+ # Wrong assumptions about env handling
+ tests/test_env.py::TestEnv::test_change_env
+ tests/test_env.py::TestEnv::test_dictlike
+ tests/test_local.py::TestLocalPath::test_iterdir
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p pytest_mock -p timeout
+}
+
+pkg_postinst() {
+ optfeature "remote commands via ssh" dev-python/paramiko
+ optfeature "progress bars in jupyter" dev-python/ipywidgets
+ optfeature "colored output in jupyter" dev-python/ipython
+ optfeature "images on the command line" dev-python/pillow
+}