summaryrefslogtreecommitdiff
path: root/dev-python/plotly-geo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/plotly-geo
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/plotly-geo')
-rw-r--r--dev-python/plotly-geo/Manifest3
-rw-r--r--dev-python/plotly-geo/metadata.xml20
-rw-r--r--dev-python/plotly-geo/plotly-geo-1.0.0.ebuild20
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/plotly-geo/Manifest b/dev-python/plotly-geo/Manifest
new file mode 100644
index 000000000000..58fda8cd065d
--- /dev/null
+++ b/dev-python/plotly-geo/Manifest
@@ -0,0 +1,3 @@
+DIST plotly-geo-1.0.0.tar.gz 23718591 BLAKE2B f78b36cd7ac6ec10e830f6be5758ed31ad2382882454d96ef652a73a11aa9b3be46ea24fd3f49a6189d9fd9eeaa89ca6777c691be9fc65f4d2a04a4d2bd58823 SHA512 977621c0fc84a6c72b2a91bcba27cc25b277f32cc87a7098675b3d7cb8c468a8291ef66397f3ceb45fbaa3484eba53d7649f809cf9d02af6309562af0b4fdf4a
+EBUILD plotly-geo-1.0.0.ebuild 409 BLAKE2B b4698ae662e4a441ec056e679e8f21225210ecf538e0dc884d8a99d0a88b48ea4b09cb0d977996c1b2136d74ce73aa3cd4f8abe0872b518a9c2910a18a1f8e02 SHA512 8913c543dfbeec6d7f37523c9a29f99a39954b675d2ebf57cadfbd46edd173dada25c6206e7b450a9c56c0ec2cc5d47036b2eeb38090ffea8a97c09892137bfe
+MISC metadata.xml 710 BLAKE2B 633a653c6685aa7653f7bd98dcaf52b79d2cf21697312e0547572ce2af049fc42c46769e6072af0021228bd0ab9a2b79cedfcc7aac8c9334eaec035598124d71 SHA512 cadd4997b878844c4d425f0c2c4515f9ed8d91258ff393b317b8c7f946cdcb8ac8c00ed0c15731e3b7b58b02759f621aa0f4e773817cef6de5aa3b962456fd31
diff --git a/dev-python/plotly-geo/metadata.xml b/dev-python/plotly-geo/metadata.xml
new file mode 100644
index 000000000000..301f9875d592
--- /dev/null
+++ b/dev-python/plotly-geo/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python plotting library for collaborative, interactive, publication-quality
+ graphs. Plotly is an online collaborative data analysis and graphing tool.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">plotly</remote-id>
+ <remote-id type="github">plotly/plotly.py</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/plotly-geo/plotly-geo-1.0.0.ebuild b/dev-python/plotly-geo/plotly-geo-1.0.0.ebuild
new file mode 100644
index 000000000000..8e9ea4411290
--- /dev/null
+++ b/dev-python/plotly-geo/plotly-geo-1.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Browser-based graphing library for Python"
+HOMEPAGE="https://plot.ly/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/plotly[${PYTHON_USEDEP}]
+"