summaryrefslogtreecommitdiff
path: root/dev-python/plette/plette-0.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-27 08:42:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-27 08:42:41 +0100
commit0fcaac21e786bd7911b1e8f436cd885c5e2f6437 (patch)
treeba392915815492b0ce486fc0e3ad5afb4a849b6f /dev-python/plette/plette-0.4.4.ebuild
parente30edd47e1804bf3ed1ea7be2eac67f4b8cd9f38 (diff)
gentoo auto-resync : 27:10:2023 - 08:42:41
Diffstat (limited to 'dev-python/plette/plette-0.4.4.ebuild')
-rw-r--r--dev-python/plette/plette-0.4.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/plette/plette-0.4.4.ebuild b/dev-python/plette/plette-0.4.4.ebuild
new file mode 100644
index 000000000000..2592ab986b58
--- /dev/null
+++ b/dev-python/plette/plette-0.4.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Structured Pipfile and Pipfile.lock models"
+HOMEPAGE="
+ https://github.com/sarugaku/plette
+ https://pypi.org/project/plette/
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/cerberus[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest