summaryrefslogtreecommitdiff
path: root/dev-python/platformdirs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-python/platformdirs
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest3
-rw-r--r--dev-python/platformdirs/metadata.xml11
-rw-r--r--dev-python/platformdirs/platformdirs-2.0.2.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
new file mode 100644
index 000000000000..d8fd843e8ae0
--- /dev/null
+++ b/dev-python/platformdirs/Manifest
@@ -0,0 +1,3 @@
+DIST platformdirs-2.0.2.gh.tar.gz 11365 BLAKE2B 53257c69f26dde3a0031c991cd6b5c72b361084342617f5c0590007a11a1d7d6e3c925dd6a8d73d3553cf1cc1d2b9fdf74fd0553d6b8891ef6b21d64bc0e256f SHA512 7cdfbcb4e37f2b4b551f3d685a40780518f9ba9c333cef0664965abaca320a10f6e944f967c0b0ba2d00e80df04b0e1e03426e6d1291e28d8f64128f50ebc1fc
+EBUILD platformdirs-2.0.2.ebuild 594 BLAKE2B 6ffbd439318d426e4d929c4f06370e6bdfadffeb90650594f1091af512f6bc1e8880f64a05e521d79bd407b66fb0f8f7fd3264c01ac8be79212b1352c8ebae81 SHA512 ad6637b33ff03b9f3af792f45fc090dd4840069911e85996b3d5ab874e54e0e9a3235536904bfa945c88e58b0b9308d04a838e31797873ce8e33a200e8245bbe
+MISC metadata.xml 358 BLAKE2B 59aae3db7ff7375600e504797a7fe4dbd4c0119d5b3fa31ef523854d8a8cd54ee60131f9bac4f608dbb5740a1e9dcf27d47cca75c7c83de4850600eb02aae2fd SHA512 09d5618647fdc5104705ac94e3af0a3bac586e27105f95d14c827b10265355a53deaa66483c12567596c2c4e8285c1cc0520f5475a1404aca3b1d677792d7654
diff --git a/dev-python/platformdirs/metadata.xml b/dev-python/platformdirs/metadata.xml
new file mode 100644
index 000000000000..37b79471151e
--- /dev/null
+++ b/dev-python/platformdirs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">platformdirs/platformdirs</remote-id>
+ <remote-id type="pypi">platformdirs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/platformdirs/platformdirs-2.0.2.ebuild b/dev-python/platformdirs/platformdirs-2.0.2.ebuild
new file mode 100644
index 000000000000..854f3231a6f5
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-2.0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/"
+SRC_URI="
+ https://github.com/platformdirs/platformdirs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/appdirs[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest