summaryrefslogtreecommitdiff
path: root/dev-python/platformdirs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-16 10:42:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-16 10:42:35 +0100
commit4c16e0a214824f15f09396e359db4f1f5c086fec (patch)
treebfacafd52495915db60285b30438af8bc216d18a /dev-python/platformdirs
parent668b36c015ae61191cf7d5007b0afdbdcedab441 (diff)
gentoo auto-resync : 16:07:2023 - 10:42:35
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest2
-rw-r--r--dev-python/platformdirs/platformdirs-3.9.1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index 4fbd3c05df0e..e661f61c4feb 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -1,5 +1,7 @@
DIST platformdirs-3.8.0.tar.gz 18451 BLAKE2B cac717c3968fd20b7bdac464443cedcdc50b04b732ae8a212fcb946170ad1553ffae82cbdca05c2cf01ebbc4383216cd0f0afe84cddc2ce6107f10fd40213542 SHA512 64937f3e9e03a9ec8dc2068777dfe553ec09cef62ce53a753608bd9a73e0afaa4489c98046e7b4b3fdbded237cf2813bfd306a6d5ad5788031b6857d8d4fa430
DIST platformdirs-3.8.1.tar.gz 18533 BLAKE2B d1d669fe76e52637f59c32ddb93920988821a1f1720d6b91042f80abedafc1d6dbcd5f744f22f5502121dc0b12285001cbde63e923e8159f139342a9497459e2 SHA512 85d7781e4ef0755bf9a7a4d90b92ea06f497081ec4c5438780f12876a1006b2e591c1b182f6648cad19039d1bd7611cf0c2215015653bafbad2cc529f27d94e7
+DIST platformdirs-3.9.1.tar.gz 18836 BLAKE2B d673573005e97895e4d665e1539805be7c4355d8de166481625f76fab250779e8efa81d86374fc388b24d8cc8d892f61b6dda113cdbb9419fff3357006c9b7e6 SHA512 c41d8be17c9336b5eba9dc15beb2d6db4b53d2ac06c51439542490019e25c091351c266f11fc4998b8eef00eb91399c464ac59b318bcd1ef14ebbd8350ae2c50
EBUILD platformdirs-3.8.0.ebuild 1326 BLAKE2B 02a40864be04dfe30c609d82652dac8ea264fdcf5e5fa7802cccd67aea42fef23fa674fac448cbe4af75e22a60e029fe00ab49a82529b45e02786d36fbbd6107 SHA512 97ac223f0e44101860803b0a109f3ba4d9f521b43f30d7f3ae79cd6745819bfba6ca46464323da9a0483c8a0f466dfe406d3928fe567323e6579e7adfd4d97ed
EBUILD platformdirs-3.8.1.ebuild 1334 BLAKE2B 200f71291e7e4d5986d17b6cdb7f2357eba9560c3b3a827f70ecdd590170b12fcb7a5d349fb249e2dcddcd5be2b17fcbd852bfa637cbf0f94c16ee07d43408c5 SHA512 4e6095aabd727e20f53ee1e381af4782910c33d1806c311f6394740a9b2cdaf7fe5491fc8408a7e0bbb090b8d4da1163404149e6ce1238823eae14a0a02b6772
+EBUILD platformdirs-3.9.1.ebuild 1334 BLAKE2B 200f71291e7e4d5986d17b6cdb7f2357eba9560c3b3a827f70ecdd590170b12fcb7a5d349fb249e2dcddcd5be2b17fcbd852bfa637cbf0f94c16ee07d43408c5 SHA512 4e6095aabd727e20f53ee1e381af4782910c33d1806c311f6394740a9b2cdaf7fe5491fc8408a7e0bbb090b8d4da1163404149e6ce1238823eae14a0a02b6772
MISC metadata.xml 383 BLAKE2B b8c8c1593d154e7a38ca4bc450c14ca21f2411ea1d71f67e9631c1def0acace43ebb6e67adc0c4a1f5f14aadfbce44d0d815fc3696410bef66c826fd5fb00a45 SHA512 f4ba6722e1cf661b3febe10bb15755a9cbc30226a08bdcabfa3d80be87b42d662d6a1edb3412ad79e8f36836a6dd4fd91a83dae29725ec47041056dc1f1f9b75
diff --git a/dev-python/platformdirs/platformdirs-3.9.1.ebuild b/dev-python/platformdirs/platformdirs-3.9.1.ebuild
new file mode 100644
index 000000000000..70e821d796fb
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-3.9.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "hatchling' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "${PN}"
+ version = "${PV}"
+ description = 'A small Python package for determining appropriate platform-specific dirs, e.g. a "user data dir".'
+ EOF
+ # sigh
+ cat > src/platformdirs/version.py <<-EOF || die
+ __version__ = version = '${PV}'
+ __version_tuple__ = version_tuple = (${PV//./, })
+ EOF
+}