summaryrefslogtreecommitdiff
path: root/dev-python/platformdirs/platformdirs-2.5.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-07 09:21:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-07 09:21:27 +0000
commit85ba3f2cfe9ff2b952efb1f3c3c08840f8093246 (patch)
treec8adb7f2695744136c00d176bd0ebd80677049aa /dev-python/platformdirs/platformdirs-2.5.3.ebuild
parentf9c971dedd369d9f45a38f3fae51467e864f5324 (diff)
gentoo auto-resync : 07:11:2022 - 09:21:27
Diffstat (limited to 'dev-python/platformdirs/platformdirs-2.5.3.ebuild')
-rw-r--r--dev-python/platformdirs/platformdirs-2.5.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/platformdirs/platformdirs-2.5.3.ebuild b/dev-python/platformdirs/platformdirs-2.5.3.ebuild
new file mode 100644
index 000000000000..8a195e51326b
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-2.5.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+SRC_URI="
+ https://github.com/platformdirs/platformdirs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}