summaryrefslogtreecommitdiff
path: root/dev-python/pkginfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pkginfo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pkginfo')
-rw-r--r--dev-python/pkginfo/Manifest5
-rw-r--r--dev-python/pkginfo/metadata.xml11
-rw-r--r--dev-python/pkginfo/pkginfo-1.2.1.ebuild47
-rw-r--r--dev-python/pkginfo/pkginfo-1.4.2.ebuild47
4 files changed, 110 insertions, 0 deletions
diff --git a/dev-python/pkginfo/Manifest b/dev-python/pkginfo/Manifest
new file mode 100644
index 000000000000..a699f1c31c22
--- /dev/null
+++ b/dev-python/pkginfo/Manifest
@@ -0,0 +1,5 @@
+DIST pkginfo-1.2.1.tar.gz 31072 BLAKE2B 57ce5f6147b97af513dfdc6137180e5561822096cdbd21b673c49522384622c58f9eba8c65f24b54bc1e76dc0c6feede5d43e8aac945d94ffe79ea220e830470 SHA512 8a530a164befdcbc6f1f550e106880e14e9d2c762a5e1055f926ccf0228d9e2312f11598454ef015e97dccb78ac7aeb7309f34279590cd318c19c2bd9a29ed2a
+DIST pkginfo-1.4.2.tar.gz 33539 BLAKE2B d3cfc6bf7a9e748902b1f63434c745d8abf4e144c0a2b5d7a90236bfc2ce7f94922b0e08e5a08b13ba2025159bd90fecee25d9abdb283e7d52de0d34386aba59 SHA512 536628a2a2472e999695a115449a76f971453aea7ac3a08f10d9b08dfdf4a7b8e67c6010c6f18d300472a6afc8dff33331c955cc2f7bdb357504cd6a36390da3
+EBUILD pkginfo-1.2.1.ebuild 1401 BLAKE2B 7d4c17ca90337f74e1cf9199e79e61201f594062a43a6b5389c772ec103725751e442788a9c483462c02c2c8325b9faf5e9de3cb8bf76dca64f1679da14ada29 SHA512 38d0801cf0398113196817412cc69f95ed0501e40578899e73a35d11fc41aabf996e29ca87eae5472a0bc03ced5f95c2bcd5c9a0c06676b0e86179c9c62855e8
+EBUILD pkginfo-1.4.2.ebuild 1340 BLAKE2B c53e2b234fe852e272317a04651caece625ed8f786980d04a214df4c869aaf61d3df29406774108f88a55bbcd6a401138c5e8de3d16292f37f954e92dece9d3a SHA512 b67723e42bf40fa9ca9689f11591978e0af9f9432a374f0f8dcd9880ba53f8065fc1c3014d6cf8da922b5eb95f230ce101f1da484e3f6738f836b40f61d4bc63
+MISC metadata.xml 320 BLAKE2B 70ca2a2666e83f11a892b1c3e155512ebb6992f2b02911aa86609ba66ac72ce4c5af72acf513c92b6a9d542d510379ed6963a94a4a1e16d0909c2461e8b6d5ee SHA512 8f2cf51568e86fb0ebbaf5eb2476f6c7f7121abecec606626aafe5395b2e9530009e77be890d389daa563b6ee47af311cbdeb121518351b0e99da0c591c0502c
diff --git a/dev-python/pkginfo/metadata.xml b/dev-python/pkginfo/metadata.xml
new file mode 100644
index 000000000000..c10553350506
--- /dev/null
+++ b/dev-python/pkginfo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pkginfo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pkginfo/pkginfo-1.2.1.ebuild b/dev-python/pkginfo/pkginfo-1.2.1.ebuild
new file mode 100644
index 000000000000..fa3f709090a4
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="https://pypi.org/project/pkginfo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86"
+IUSE="doc examples"
+
+LICENSE="MIT"
+SLOT="0"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ # Disable tests that seek to read the version of pkginfo from an installed state
+ # These test will still become installed and testable once installed
+ sed -e 's:test_w_directory_no_EGG_INFO:_&:' \
+ -e 's:test_w_module_and_metadata_version:_&:' \
+ -e 's:test_w_package_name_and_metadata_version:_&:' \
+ -i pkginfo/tests/test_utils.py || die
+ sed -e 's:test_ctor_w_path_nested_egg_info:_&:' \
+ -i pkginfo/tests/test_develop.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Test ${test} failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/.build/html/. )
+ use examples && local EXAMPLES=( docs/examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pkginfo/pkginfo-1.4.2.ebuild b/dev-python/pkginfo/pkginfo-1.4.2.ebuild
new file mode 100644
index 000000000000..cabf02ebdad9
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.4.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="https://pypi.org/project/pkginfo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Disable tests that seek to read the version of pkginfo from an installed state
+ # These test will still become installed and testable once installed
+ sed -e 's:test_w_directory_no_EGG_INFO:_&:' \
+ -e 's:test_w_module_and_metadata_version:_&:' \
+ -e 's:test_w_package_name_and_metadata_version:_&:' \
+ -i pkginfo/tests/test_utils.py || die
+ sed -e 's:test_ctor_w_path_nested_egg_info:_&:' \
+ -i pkginfo/tests/test_develop.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/.build/html/. )
+ distutils-r1_python_install_all
+}