summaryrefslogtreecommitdiff
path: root/dev-python/pkginfo/pkginfo-1.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-04 11:43:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-04 11:43:04 +0000
commit56a597689e7509193b0924a635d2022f21b1a3e4 (patch)
tree476358a5cea634edc1fb0504f6ec03b282cfb83e /dev-python/pkginfo/pkginfo-1.10.0.ebuild
parent57e2174dcd454b41778b7b437f88d0a9f1a6e428 (diff)
gentoo auto-resync : 04:03:2024 - 11:43:04
Diffstat (limited to 'dev-python/pkginfo/pkginfo-1.10.0.ebuild')
-rw-r--r--dev-python/pkginfo/pkginfo-1.10.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pkginfo/pkginfo-1.10.0.ebuild b/dev-python/pkginfo/pkginfo-1.10.0.ebuild
new file mode 100644
index 000000000000..a53f172b6846
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.10.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="
+ https://launchpad.net/pkginfo/
+ https://pypi.org/project/pkginfo/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs