summaryrefslogtreecommitdiff
path: root/dev-python/pkgconfig
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pkgconfig
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pkgconfig')
-rw-r--r--dev-python/pkgconfig/Manifest3
-rw-r--r--dev-python/pkgconfig/metadata.xml12
-rw-r--r--dev-python/pkgconfig/pkgconfig-1.2.2.ebuild32
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pkgconfig/Manifest b/dev-python/pkgconfig/Manifest
new file mode 100644
index 000000000000..2a6c6d9adeea
--- /dev/null
+++ b/dev-python/pkgconfig/Manifest
@@ -0,0 +1,3 @@
+DIST pkgconfig-1.2.2.tar.gz 5305 BLAKE2B 39fe5e05489e4eb8fefce66f23820d96039f5dfb82148e8ac2d691644aa2d4f1205bfa483f9fdc69837b7956834d1525d85281ba6aa0a0c079748336d47708c7 SHA512 88cfb27755297871c500f37c422da5d4ae30a14e0b9974afbe63f22c59746be0d175b65d9e3d2ed315b4d942046e7c18be062aef914199c99070a2767699848b
+EBUILD pkgconfig-1.2.2.ebuild 702 BLAKE2B 0c0d947f27c24aaa4f8f0faaa635dcadef6cdc3a4fd6129a7e7eec91b0ed9467edf02669dee63e7aac563e37cff8ec263b8d715ff81821bdd58d0380c6fe6c82 SHA512 ecfeb98b002081bc596fad3b5d909b80ab2a4cea677b15b8d238382dc7bb6ee5c73f8102f5c8138476f17beac92e3c7f4d7263faf742f57f752b8da7e52263d1
+MISC metadata.xml 379 BLAKE2B 6d974351e99e999b08f6c18b48ecd4dcafb45452f724d6d038a2307a205ca00f300bf1c60761bc9e63726426f499c2622673dd677afb263c957fb398f264504f SHA512 2e92f2bbce0b0b8d9524ffdd2950c90ce34776d497c3d3ad47f239cfc562cbc7f52c3690b9df132f8466e386783b5287e63011c0bc8b1ab2ea839d1fc3fd9af4
diff --git a/dev-python/pkgconfig/metadata.xml b/dev-python/pkgconfig/metadata.xml
new file mode 100644
index 000000000000..7c0bf4d1bc90
--- /dev/null
+++ b/dev-python/pkgconfig/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pkgconfig</remote-id>
+ <remote-id type="github">matze/pkgconfig</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pkgconfig/pkgconfig-1.2.2.ebuild b/dev-python/pkgconfig/pkgconfig-1.2.2.ebuild
new file mode 100644
index 000000000000..8261cbe1a901
--- /dev/null
+++ b/dev-python/pkgconfig/pkgconfig-1.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Interface Python with pkg-config"
+HOMEPAGE="https://pypi.org/project/pkgconfig/ https://github.com/matze/pkgconfig"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -e '/nose/d' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die
+}