summaryrefslogtreecommitdiff
path: root/dev-python/pipx/pipx-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-29 07:40:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-29 07:40:48 +0000
commit8d12644534a171c85dd84343b976054ad30faa6d (patch)
tree1bbdbe1f1cc6b952253c203b199150ab19502004 /dev-python/pipx/pipx-1.3.1.ebuild
parentdd5af718da993c9a6f040afb037ba1246974c6e5 (diff)
gentoo auto-resync : 29:12:2023 - 07:40:48
Diffstat (limited to 'dev-python/pipx/pipx-1.3.1.ebuild')
-rw-r--r--dev-python/pipx/pipx-1.3.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/pipx/pipx-1.3.1.ebuild b/dev-python/pipx/pipx-1.3.1.ebuild
deleted file mode 100644
index 01daa9316fba..000000000000
--- a/dev-python/pipx/pipx-1.3.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Install and Run Python Applications in Isolated Environments"
-HOMEPAGE="
- https://pypi.org/project/pipx/
- https://pypa.github.io/pipx/
-"
-# no tests in sdist
-SRC_URI="
- https://github.com/pypa/pipx/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/argcomplete-1.9.4[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.10)
- >=dev-python/userpath-1.9.0[${PYTHON_USEDEP}]
-"
-
-PROPERTIES="test_network"
-RESTRICT="test"
-distutils_enable_tests pytest
-
-python_test() {
- epytest --net-pypiserver
-}