summaryrefslogtreecommitdiff
path: root/dev-python/pipdeptree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-14 16:34:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-14 16:34:53 +0000
commitdfd7c8230bca447ee0b09dc11150181b0b3148e2 (patch)
tree11f7e2fe7599d1e364bdfb4176f2f41e99a3c603 /dev-python/pipdeptree
parentcd8b6c60f3cbb06647bf3d03fb2ac29ccfc31c8f (diff)
gentoo auto-resync : 14:11:2023 - 16:34:53
Diffstat (limited to 'dev-python/pipdeptree')
-rw-r--r--dev-python/pipdeptree/Manifest3
-rw-r--r--dev-python/pipdeptree/files/pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch26
-rw-r--r--dev-python/pipdeptree/pipdeptree-2.13.1.ebuild41
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/pipdeptree/Manifest b/dev-python/pipdeptree/Manifest
index 698ea8d0136a..8e62f5e775ba 100644
--- a/dev-python/pipdeptree/Manifest
+++ b/dev-python/pipdeptree/Manifest
@@ -1,3 +1,6 @@
+AUX pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch 1018 BLAKE2B 18405bf1f1ba5a457c9643738258df5d1c3d5ed709954dd274560ae9cbf139f336b75b2c896d9d8bdfe24c4d2cb98ea3e0391d73ac05ba1e38766f2cfa04a431 SHA512 da732fe18cc3f49ed3994133e8a5eefe4c6f8ebf18dad3caeb057bcdbab38f5936c245271d6ff534f3cb6069255e13291a9033594148e70e486fd85d5b9e711e
DIST pipdeptree-2.13.0.tar.gz 32980 BLAKE2B 37a7ecf2cef1fb2533655b1b911216ed5d069ce639198896517a49be010b1697df2a81aecba001dfbcd9b67618411754a97ad198f2e2c32d73d2104020d5eb01 SHA512 eccc41e1428d2f7146386a6aa0e1c5833302b9eaaa810250cb8029f8cf7f8f8173477553f143835b4dfac318331b9b7467493a3fcae15569d7d371d58b27963f
+DIST pipdeptree-2.13.1.tar.gz 33139 BLAKE2B e7044303f09ad3952e14f79ec11e01a54e9c34ff5b4430094a968602c8a97388eadd4e021c97c97c1767d7ae02b7070ff6e4ec934aef6036b98bf2553d2344a0 SHA512 18c73a8ef458b0a241d967da40453fb8a9fc6550cbd2c21eecca9a81f011b896622fb45a81b79e30eb990454b6f518a1fcc02cb25bb2c5ca988b44e040264e26
EBUILD pipdeptree-2.13.0.ebuild 453 BLAKE2B 562be67a68b16bfa3d55e22109a0ee3822b7e49ea029433f875132e92e474d87c84fa6086485d819bebb2a3eac139b34b2f03be9f24674d3096898161968c4f9 SHA512 87f35cfb01a8a1cf83402b5647f32197953e7f7e18ed164b4a0fa29c6d02c8a3d7dfb885ac11ef511f606d7467e86d0618c7b9d3026d286f5bfdc7102030a113
+EBUILD pipdeptree-2.13.1.ebuild 892 BLAKE2B 1e5c060644e60d594bc2b7d257d35246aff7f885331752ea4dc93a8fbd801a7de6316fea450c120245905a692844fa89b221ba5da6a9c930c86c29bd44b29296 SHA512 4c40888be4745514e7ef2c8638b92615f3b0e86557a1350742b366dfd235d31183f092deda8b4f6f02bc8061d425e6934c9ea0f7167dc46de06f8a3ea6e54f23
MISC metadata.xml 545 BLAKE2B cf435473fd95ac0a5bafe2b52ddd78e09c16eb190e3a979924525607fc7ab152e249419e3a21d246cd1354a714116c6c0953ed55d1efceafae441ee282c2b1eb SHA512 ad2e8d4e7bac53b26ea0bb5c2f65e0c9dc8d30afc8c569d73bac820b2dda6a343b96e52abd0353e3f50269fb431e46bd3b51b3768d9c24f658fd2eca6cc1ce97
diff --git a/dev-python/pipdeptree/files/pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch b/dev-python/pipdeptree/files/pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch
new file mode 100644
index 000000000000..5cc4b1ca580d
--- /dev/null
+++ b/dev-python/pipdeptree/files/pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch
@@ -0,0 +1,26 @@
+https://github.com/tox-dev/pipdeptree/pull/302
+
+From 8a2ccfe062d8978f010e2e4bd3f8e8b9e46ecbce Mon Sep 17 00:00:00 2001
+From: Alfred Wingate <parona@protonmail.com>
+Date: Tue, 14 Nov 2023 08:36:09 +0200
+Subject: [PATCH] Expect hpy in pypy versions >= 7.3.3
+
+Signed-off-by: Alfred Wingate <parona@protonmail.com>
+--- a/tests/test_non_host.py
++++ b/tests/test_non_host.py
+@@ -33,7 +33,11 @@ def test_custom_interpreter(
+ if implementation == "CPython":
+ expected = {"pip", "setuptools", "wheel"}
+ elif implementation == "PyPy":
+- expected = {"cffi", "greenlet", "pip", "readline", "setuptools", "wheel"}
++ # hpy added in 7.3.2, enabled in 7.3.3
++ if sys.pypy_version_info >= (7, 3, 3):
++ expected = {"cffi", "greenlet", "hpy", "pip", "readline", "setuptools", "wheel"}
++ else:
++ expected = {"cffi", "greenlet", "pip", "readline", "setuptools", "wheel"}
+ else:
+ raise ValueError(implementation)
+ if sys.version_info >= (3, 12):
+--
+2.42.1
+
diff --git a/dev-python/pipdeptree/pipdeptree-2.13.1.ebuild b/dev-python/pipdeptree/pipdeptree-2.13.1.ebuild
new file mode 100644
index 000000000000..419254577378
--- /dev/null
+++ b/dev-python/pipdeptree/pipdeptree-2.13.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="Utility for displaying installed packages in a dependency tree"
+HOMEPAGE="
+ https://github.com/tox-dev/pipdeptree/
+ https://pypi.org/project/pipdeptree/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # https://github.com/tox-dev/pipdeptree/pull/302
+ "${FILESDIR}/pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature \
+ "visualising the dependency graph with --graph-output" \
+ dev-python/graphviz
+}