summaryrefslogtreecommitdiff
path: root/dev-python/pipdeptree/pipdeptree-2.21.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
commit482a48c0e1675b1e92663b8b5222bb7261aa7956 (patch)
treeb81e02db1810214fc690a762e3a9c687d0f0c5ab /dev-python/pipdeptree/pipdeptree-2.21.0.ebuild
parent37bccfe5e76c5740c4ef5ba1179e9488d8404075 (diff)
gentoo auto-resync : 13:07:2024 - 12:26:41
Diffstat (limited to 'dev-python/pipdeptree/pipdeptree-2.21.0.ebuild')
-rw-r--r--dev-python/pipdeptree/pipdeptree-2.21.0.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/pipdeptree/pipdeptree-2.21.0.ebuild b/dev-python/pipdeptree/pipdeptree-2.21.0.ebuild
deleted file mode 100644
index dae7c7c1be5b..000000000000
--- a/dev-python/pipdeptree/pipdeptree-2.21.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1 pypi optfeature
-
-DESCRIPTION="Utility for displaying installed packages in a dependency tree"
-HOMEPAGE="
- https://github.com/tox-dev/pipdeptree/
- https://pypi.org/project/pipdeptree/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv"
-
-RDEPEND="
- >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
- >=dev-python/pip-23.1.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- dev-python/graphviz[${PYTHON_USEDEP}]
- >=dev-python/pytest-console-scripts-1.4.1[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- # https://github.com/tox-dev/pipdeptree/pull/369
- "${FILESDIR}/${P}-pypy.patch"
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p pytest_mock -p console-scripts
-}
-
-pkg_postinst() {
- optfeature \
- "visualising the dependency graph with --graph-output" \
- dev-python/graphviz
-}