summaryrefslogtreecommitdiff
path: root/dev-python/pipdeptree/pipdeptree-2.17.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-06 18:30:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-06 18:30:39 +0100
commit68a32bc9fda17e8a546c0bba9d113c4c4659f6bb (patch)
treee043bb32648a3c75289450c0f4252aaabc1d4593 /dev-python/pipdeptree/pipdeptree-2.17.0.ebuild
parent74a32c3ccafc7895a037d2b0cf73fc726286ec2e (diff)
gentoo auto-resync : 06:04:2024 - 18:30:38
Diffstat (limited to 'dev-python/pipdeptree/pipdeptree-2.17.0.ebuild')
-rw-r--r--dev-python/pipdeptree/pipdeptree-2.17.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pipdeptree/pipdeptree-2.17.0.ebuild b/dev-python/pipdeptree/pipdeptree-2.17.0.ebuild
new file mode 100644
index 000000000000..d4b8329e97ea
--- /dev/null
+++ b/dev-python/pipdeptree/pipdeptree-2.17.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="Utility for displaying installed packages in a dependency tree"
+HOMEPAGE="
+ https://github.com/tox-dev/pipdeptree/
+ https://pypi.org/project/pipdeptree/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
+ >=dev-python/pip-23.1.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # https://github.com/tox-dev/pipdeptree/pull/302
+ "${FILESDIR}/pipdeptree-2.17.0-expect-hpy-in-pypy-7.3.3.patch"
+ "${FILESDIR}/pipdeptree-2.13.2-fix-pypy-7.3.14.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock
+}
+
+pkg_postinst() {
+ optfeature \
+ "visualising the dependency graph with --graph-output" \
+ dev-python/graphviz
+}