summaryrefslogtreecommitdiff
path: root/dev-python/pipdeptree/pipdeptree-2.16.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-06 00:30:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-06 00:30:33 +0100
commit9323524b4d44f4ec3dc923bd8e9ea04bdde8a067 (patch)
tree8ca7b8c58d4e70389d5d4672ebd86cb475cf9f80 /dev-python/pipdeptree/pipdeptree-2.16.0.ebuild
parent8c11cf748cc296d6338a189106a8cc9e3a1e0948 (diff)
gentoo auto-resync : 06:04:2024 - 00:30:33
Diffstat (limited to 'dev-python/pipdeptree/pipdeptree-2.16.0.ebuild')
-rw-r--r--dev-python/pipdeptree/pipdeptree-2.16.0.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/pipdeptree/pipdeptree-2.16.0.ebuild b/dev-python/pipdeptree/pipdeptree-2.16.0.ebuild
deleted file mode 100644
index 8c26d7357bda..000000000000
--- a/dev-python/pipdeptree/pipdeptree-2.16.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi optfeature
-
-DESCRIPTION="Utility for displaying installed packages in a dependency tree"
-HOMEPAGE="
- https://github.com/tox-dev/pipdeptree/
- https://pypi.org/project/pipdeptree/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv"
-
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- dev-python/graphviz[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- # https://github.com/tox-dev/pipdeptree/pull/302
- "${FILESDIR}/pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch"
- "${FILESDIR}/pipdeptree-2.13.2-fix-pypy-7.3.14.patch"
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # broken when flufl.lock is actually installed
- # https://github.com/tox-dev/pipdeptree/issues/326
- tests/_models/test_dag.py::test_package_dag_from_pkgs_uses_pep503normalize
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p pytest_mock
-}
-
-pkg_postinst() {
- optfeature \
- "visualising the dependency graph with --graph-output" \
- dev-python/graphviz
-}