summaryrefslogtreecommitdiff
path: root/dev-python/pip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-12 00:01:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-12 00:01:15 +0100
commitd72a987a342949e200b5e9decbd71f246da53788 (patch)
treeea9d3f4ec74bd6ab18582852d7958d3f3176dfea /dev-python/pip
parentc035b2b83f0e94c4b2e82184f00bcef874e6276b (diff)
gentoo auto-resync : 12:05:2024 - 00:01:15
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/Manifest2
-rw-r--r--dev-python/pip/pip-24.0.ebuild15
2 files changed, 13 insertions, 4 deletions
diff --git a/dev-python/pip/Manifest b/dev-python/pip/Manifest
index b20fef99c82a..9a786e0f92c1 100644
--- a/dev-python/pip/Manifest
+++ b/dev-python/pip/Manifest
@@ -1,5 +1,5 @@
AUX pip-23.1-no-coverage.patch 1836 BLAKE2B f8c95ed26d5a7cba2a516b8d134ddd9901fd7d39dc8bf174397ab2afab33e93c4af342195b5b4d7b0aedc642493f1ed2ee474c74e16e285f335dcdcf531b1777 SHA512 c63929cc5324b2a741a4c1ebb4990c376eb6a4c0f39370e456b674ce3cfbdf10471ec48cf9368fccba9264fd9d4a5667988116163e73772496f28d52986ff111
AUX pip-23.3.1-no-color.patch 1767 BLAKE2B b81a4b814e2e84e7c0424870d1a86ba7fde91400bfad127c696112544b294623ba9d580f503f01a8399a569a9a5880d38d1d09c98b9364c9b59915adb3a9b453 SHA512 c89be77fbd8049a1e6fd12ef4227926ff641c1797f91bbe91b6152016a1e7dff5e323d8ff0961948225ef854d52de972f74c8e37f48e8aee78e529f9ec8b3b3f
DIST pip-24.0.gh.tar.gz 9398156 BLAKE2B 17a7ed9e15e9b8efa0d3e3c5586dc446958b62cf9ba52155a0d1ad97a3e212ee7a08a0e88a592718fc3d542eb8f434155a75cb98d90c008904bd8f59bd2b40b6 SHA512 0c2ecb2ecde4f155c83468d35bc4f52f37efffc16821ae7c706d035e1e8cc3709b41cb10f8140ff09205e8bbdba2c76128ad76d1cbd18401328b619228e834df
-EBUILD pip-24.0.ebuild 4195 BLAKE2B 4bde20ee8e89d56bfe0642a2b0020579829a79c069ffe6ecd2bfed8ea40894a9e284914563021b4d4838dea037308c05b1706f4990153b610418883292970d39 SHA512 e194b652472fe00e6073883c958eae8a7506587bbecba5ad093a7b7e8931470cab123ca28e0995436599313abc29e51d2b3035e5db15d1534828af0d390ccbd9
+EBUILD pip-24.0.ebuild 4559 BLAKE2B 6f34aa0dcd0c78b53d63c0dd523ec1b397186e8d9efc90781812d94e96138630653a896636931d2095c59065065b9140d104ebb9cf178858de0e5985aca4e05b SHA512 587b9eb40e71ee078d74853dfb0694ae2733fed6f54fb4ce48f410113179f15c55d17efc47e8ad0dc70d704302d731240ba0aad77c40450daecffc522d6f0320
MISC metadata.xml 392 BLAKE2B 94ea3de1220cb9ca64ae1186597789cc83a54adfe44695932c07dd5065df0e5f9ee5078a495e3a12563b36809d781d8ab86bb6c92c485c023199d92547b74f27 SHA512 603199f6547105f3bb64f4fcaf004e9ef62fa2e0f8ec6eab56078119684b0f5119161e0f164fe02b2cf6dd6b115588c9ef77d727eeb6d138e281f1cb0bcb5de9
diff --git a/dev-python/pip/pip-24.0.ebuild b/dev-python/pip/pip-24.0.ebuild
index 8e9ed0858608..ffcadb6fa1cb 100644
--- a/dev-python/pip/pip-24.0.ebuild
+++ b/dev-python/pip/pip-24.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# please bump dev-python/ensurepip-pip along with this package!
DISTUTILS_USE_PEP517=setuptools
-PYTHON_TESTED=( python3_{10..12} )
+PYTHON_TESTED=( python3_{10..13} )
PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" pypy3 )
PYTHON_REQ_USE="ssl(+),threads(+)"
@@ -25,8 +25,8 @@ SRC_URI="
LICENSE="MIT"
# bundled deps
LICENSE+=" Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MPL-2.0 PSF-2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="test-rust"
RDEPEND="
@@ -109,6 +109,15 @@ python_test() {
fi
case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # hacky upstream time mocking stopped working, they have it
+ # failing on CI already too
+ tests/unit/test_base_command.py::test_log_command_success
+ tests/unit/test_base_command.py::test_log_command_error
+ tests/unit/test_base_command.py::test_log_file_command_error
+ )
+ ;;
python3.10)
EPYTEST_DESELECT+=(
# no clue why they fail
@@ -122,7 +131,7 @@ python_test() {
local -x PIP_DISABLE_PIP_VERSION_CHECK=1
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local EPYTEST_XDIST=1
- epytest -m "not network"
+ epytest -m "not network" -o tmp_path_retention_policy=all
}
python_install_all() {