summaryrefslogtreecommitdiff
path: root/dev-python/pillowfight
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pillowfight
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pillowfight')
-rw-r--r--dev-python/pillowfight/Manifest3
-rw-r--r--dev-python/pillowfight/metadata.xml12
-rw-r--r--dev-python/pillowfight/pillowfight-0.2.ebuild22
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pillowfight/Manifest b/dev-python/pillowfight/Manifest
new file mode 100644
index 000000000000..fb1bce8a970f
--- /dev/null
+++ b/dev-python/pillowfight/Manifest
@@ -0,0 +1,3 @@
+DIST pillowfight-0.2.tar.gz 2628 BLAKE2B c0bc947b679a5372e3af722a3d2cab97b0fb97a245f6319c7ff10cbfa5409fc7c2f325b7f65fdedbbdcc2ad2bfff8d426c3f8691a24be77760eb427cabcb0c40 SHA512 2eff2fd0bdf5c02513ddb4838675e7b9f392135ff08a784ca2fedf06c5b96a56af75460559066cc6cded65f3d4da087ac679492b7b1dba23fb557e6ac3565e6e
+EBUILD pillowfight-0.2.ebuild 544 BLAKE2B 83b85706a3ab97ce081e8848ca93967b8566c3b681e604718261658f67cc666cccdf0bdc828838bb8fcb9b8e668ed52054eab0436e669e5f354b565c31750144 SHA512 23cf4ad6fd34a2afce616ed069a1f1e4dd95a88e9ebfaed9836bd9d4dec1852349b71e7abe401a2393c2e3008fcd5014e1a9fbb8df1a7508f87e3e3ca986e700
+MISC metadata.xml 388 BLAKE2B 2679d6d0ca4a4c6f78a35498cd13379bc0b065643ce29205f35b66a31bea52fd5986c58225acce1bb1f27e132fcc6897058f0d0dfef1b5a123bfa3c398dbc710 SHA512 63a6f23df5433c9c251cb2ef9d4a2f88a1eeaf390b88b74ed8e80468b81de9537fdcbfa9d8a62109167900ed72cd503de495283d84e1b5fd22892538e2723950
diff --git a/dev-python/pillowfight/metadata.xml b/dev-python/pillowfight/metadata.xml
new file mode 100644
index 000000000000..0916aa813f42
--- /dev/null
+++ b/dev-python/pillowfight/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">beanbaginc/pillowfight</remote-id>
+ <remote-id type="pypi">pillowfight</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pillowfight/pillowfight-0.2.ebuild b/dev-python/pillowfight/pillowfight-0.2.ebuild
new file mode 100644
index 000000000000..2851d304c925
--- /dev/null
+++ b/dev-python/pillowfight/pillowfight-0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Eases the transition from PIL to Pillow"
+HOMEPAGE="https://pypi.org/project/pillowfight/ https://github.com/beanbaginc/pillowfight"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"