summaryrefslogtreecommitdiff
path: root/dev-python/pillow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-02 05:29:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-02 05:29:41 +0100
commitc3ec60d8953748433a04137e04480e9c1a36ed4c (patch)
tree40c0804fd55099e7d00aa8d8e12f8068dbfe59d9 /dev-python/pillow
parentdafb3f89c1133d028ad628dea8b30961e0ef8498 (diff)
gentoo auto-resync : 02:07:2023 - 05:29:41
Diffstat (limited to 'dev-python/pillow')
-rw-r--r--dev-python/pillow/Manifest2
-rw-r--r--dev-python/pillow/pillow-10.0.0.ebuild133
2 files changed, 135 insertions, 0 deletions
diff --git a/dev-python/pillow/Manifest b/dev-python/pillow/Manifest
index 1b1f06070a99..61f46bc987e4 100644
--- a/dev-python/pillow/Manifest
+++ b/dev-python/pillow/Manifest
@@ -1,3 +1,5 @@
+DIST pillow-10.0.0.gh.tar.gz 50537667 BLAKE2B f0ce48e947363c16c0bb08881b42dcf845a142fe7d2162154f5ddce47bf909fc4c829dcb4365ee363680a41c247cea28eef37c879d22959ef69c9dc5adce91f4 SHA512 a963ae8398c609569e1b23d2362f6382cd888698492ba2349f9c931a04c463fbdc27a43e53d1dee8bbb1b5e88c0d5eb655f6f5e9df7d489c206b6acda0adec3a
DIST pillow-9.5.0.gh.tar.gz 50491974 BLAKE2B 663c14b89ddd1e2d49872994033a04e500d0b6eccbb8d6ce094f58ae1aaf3f215e9984f2afeb43fb83e0c3c93af1150beeb7d5f0abb77c59087901b53fd24e37 SHA512 da0c7a1bde4741ced168c013fdc7afa8af1100bba878bdaeeb9804fed4dcf70c07ed62004ab2c73694eae3d28e2d72d46c155f78b540075aafb36c8e7a5649ff
+EBUILD pillow-10.0.0.ebuild 3449 BLAKE2B 3f2353177e9e860b99a21d7e98c4fe2f5e400377c56af26a0d3ceca9383dd197e47954d2f661cd6c145cc8b7ac11a84079b851c7723a698d7aa3084357e15833 SHA512 8cb14e0135294963092c911be5860c9e9444ef1d0137e881bccf1617e61756bc4c333670f6e7866f225a20918ccfafcc95f7ac2af8be308f70517e2cb77246a5
EBUILD pillow-9.5.0.ebuild 3379 BLAKE2B 24be0608c1dbac735e4bf9b8fe01069cd1ccc4aad532bc2073c6832f06abfc6b982362f0c2a71d4dec5381f7f3b10712693b016680189495b2a5eeb69d622f21 SHA512 623bed259f3371bbd3ac6b106cd309620a31f59db736ca8f00a34d02ae1878d5b262ffec6c4d34eee3704fccea99bb3efd45dbf9ff0f1ac18962356cc42511e6
MISC metadata.xml 480 BLAKE2B b42e6b01b1572a0688ef93025a0baaa95b9fd0c3a5eabcddcea7145dd880a95f11859b255ae24a376ca792559ffcf940c67da1b19f2f579dbc6ef6de68903749 SHA512 b98a33136aef4498051370bce3295b000687ddb80b4d909b26b32af61b4e4638d07269f7924ae039420af63236aa74b51e23d2feae1c83349683073c69714582
diff --git a/dev-python/pillow/pillow-10.0.0.ebuild b/dev-python/pillow/pillow-10.0.0.ebuild
new file mode 100644
index 000000000000..56c451474659
--- /dev/null
+++ b/dev-python/pillow/pillow-10.0.0.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+# setuptools wrapper
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 toolchain-funcs virtualx
+
+MY_PN=Pillow
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python Imaging Library (fork)"
+HOMEPAGE="
+ https://python-pillow.org/
+ https://github.com/python-pillow/
+ https://pypi.org/project/Pillow/
+"
+SRC_URI="
+ https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples imagequant +jpeg jpeg2k lcms test tiff tk truetype webp xcb zlib"
+REQUIRED_USE="test? ( jpeg jpeg2k lcms tiff truetype )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ imagequant? ( media-gfx/libimagequant:= )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ jpeg2k? ( media-libs/openjpeg:2= )
+ lcms? ( media-libs/lcms:2= )
+ tiff? ( media-libs/tiff:=[jpeg,zlib] )
+ truetype? ( media-libs/freetype:2= )
+ webp? ( media-libs/libwebp:= )
+ xcb? ( x11-libs/libxcb )
+ zlib? ( sys-libs/zlib:= )
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/olefile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? (
+ ${RDEPEND}
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ || (
+ media-gfx/imagemagick[png]
+ media-gfx/graphicsmagick[png]
+ )
+ )
+"
+
+EPYTEST_DESELECT=(
+ # TODO; incompatible Qt version?
+ Tests/test_qt_image_qapplication.py::test_sanity
+)
+
+usepil() {
+ usex "${1}" enable disable
+}
+
+python_configure_all() {
+ # It's important that these flags are also passed during the install phase
+ # as well. Make sure of that if you change the lines below. See bug 661308.
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ disable_platform_guessing = True
+ $(usepil truetype)_freetype = True
+ $(usepil jpeg)_jpeg = True
+ $(usepil jpeg2k)_jpeg2000 = True
+ $(usepil lcms)_lcms = True
+ $(usepil tiff)_tiff = True
+ $(usepil imagequant)_imagequant = True
+ $(usepil webp)_webp = True
+ $(usepil webp)_webpmux = True
+ $(usepil xcb)_xcb = True
+ $(usepil zlib)_zlib = True
+ EOF
+
+ # setup.py won't let us add the right toolchain paths but it does
+ # accept additional ones from INCLUDE and LIB so set these. You
+ # wouldn't normally need these at all as the toolchain should look
+ # here anyway but it doesn't for this setup.py.
+ export \
+ INCLUDE="${ESYSROOT}"/usr/include \
+ LIB="${ESYSROOT}"/usr/$(get_libdir)
+
+ # We have patched in this env var.
+ tc-export PKG_CONFIG
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO (is clipboard unreliable in Xvfb?)
+ Tests/test_imagegrab.py::TestImageGrab::test_grabclipboard
+ )
+
+ "${EPYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
+ # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
+ epytest -p no:relaxed || die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ python_doheader src/libImaging/*.h
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples ; then
+ docinto example
+ dodoc docs/example/*
+ docompress -x /usr/share/doc/${PF}/example
+ fi
+ distutils-r1_python_install_all
+}