summaryrefslogtreecommitdiff
path: root/dev-python/picobox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/picobox
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/picobox')
-rw-r--r--dev-python/picobox/Manifest4
-rw-r--r--dev-python/picobox/files/picobox-2.2.0-fix-py3.10.patch26
-rw-r--r--dev-python/picobox/metadata.xml13
-rw-r--r--dev-python/picobox/picobox-2.2.0.ebuild30
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/picobox/Manifest b/dev-python/picobox/Manifest
new file mode 100644
index 000000000000..5bab346d4734
--- /dev/null
+++ b/dev-python/picobox/Manifest
@@ -0,0 +1,4 @@
+AUX picobox-2.2.0-fix-py3.10.patch 974 BLAKE2B 54ff67012b6ec6ba6343c955fb2b7172cfd9b210f094946b22d7452edee286841aba3105a0ceaf47fc5e500bd67331e7ebaa23d41a580ce944ce4bf371504037 SHA512 a506bf04110446c8be244bb9e9e123d3349b2f760f1e00e545787d409b01ffbd00353880ffbbbe345a1610d08db9aaab8a0187bf8f94d3dbe9f6ba1254225471
+DIST picobox-2.2.0.tar.gz 30231 BLAKE2B 9911e2e41a850b57d4a642aa454e55703e0546bdb3a5b95aa4a15747388413babaec7dc3a3f7fcb7ecae7ecd0f81dc203161975ca393f87353987825e0413355 SHA512 d127ea71637105285701ae5252e59e0c940077fbbe044ba1f42f80134ea08291344ebb6bc8bce240112a7efe0be8561c8040b43d20912f1fbd121098578a1795
+EBUILD picobox-2.2.0.ebuild 637 BLAKE2B 55137e8a40442e07b7eb9a3a5836e8de1d3b220f5ab3dae818b7af0501111c410b62a4074c40970c319bc3ea21c5374666c922ced6e5e76f116ca1b1bedf75eb SHA512 8c60f8923146c8e8722a3e9e0a5a15b2fa01dd32d5b059529c39815d5249c699c97e621ccae2344762868f666b0314e564fd4b7e58cefab25ce5da10d6ce2372
+MISC metadata.xml 394 BLAKE2B 9d5aab4a31fd6c669ed0b207281b1a5df9b48cd593efd6095353b74edba985aa2beabab3a83db01a93ecb97dabac9a06e62f82e316989d461d98897d074f6501 SHA512 fead3589983a0e6e497a67c3700f4611a5c45e17aaa3659b0ee45e5cbcd1a02b8929f373b86b43a25ce51493f6b888833fe7b64168c7eb795ce503ef1775c0ef
diff --git a/dev-python/picobox/files/picobox-2.2.0-fix-py3.10.patch b/dev-python/picobox/files/picobox-2.2.0-fix-py3.10.patch
new file mode 100644
index 000000000000..74c6f9b2193f
--- /dev/null
+++ b/dev-python/picobox/files/picobox-2.2.0-fix-py3.10.patch
@@ -0,0 +1,26 @@
+diff --git a/tests/test_box.py b/tests/test_box.py
+index c1c1ca2..d576086 100644
+--- a/tests/test_box.py
++++ b/tests/test_box.py
+@@ -402,7 +402,7 @@ def test_box_pass_unexpected_argument(boxclass):
+ with pytest.raises(TypeError) as excinfo:
+ fn(1, 2)
+
+- assert str(excinfo.value) == "fn() got an unexpected keyword argument 'd'"
++ assert "fn() got an unexpected keyword argument 'd'" in str(excinfo.value)
+
+
+ def test_box_pass_keyerror(boxclass):
+diff --git a/tests/test_stack.py b/tests/test_stack.py
+index 725d378..10129b3 100644
+--- a/tests/test_stack.py
++++ b/tests/test_stack.py
+@@ -472,7 +472,7 @@ def test_box_pass_unexpected_argument(boxclass, teststack):
+ with pytest.raises(TypeError) as excinfo:
+ fn(1, 2)
+
+- assert str(excinfo.value) == "fn() got an unexpected keyword argument 'd'"
++ assert "fn() got an unexpected keyword argument 'd'" in str(excinfo.value)
+
+
+ def test_box_pass_keyerror(boxclass, teststack):
diff --git a/dev-python/picobox/metadata.xml b/dev-python/picobox/metadata.xml
new file mode 100644
index 000000000000..4c33fc7d9bd9
--- /dev/null
+++ b/dev-python/picobox/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">picobox</remote-id>
+ <remote-id type="github">ikalnytskyi/picobox</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/picobox/picobox-2.2.0.ebuild b/dev-python/picobox/picobox-2.2.0.ebuild
new file mode 100644
index 000000000000..5a25c40a8670
--- /dev/null
+++ b/dev-python/picobox/picobox-2.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Dependency injection framework designed with Python in mind"
+HOMEPAGE="https://pypi.org/project/picobox/
+ https://github.com/ikalnytskyi/picobox"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10.patch"
+)
+
+distutils_enable_tests pytest