summaryrefslogtreecommitdiff
path: root/dev-python/phply
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-python/phply
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-python/phply')
-rw-r--r--dev-python/phply/Manifest3
-rw-r--r--dev-python/phply/metadata.xml12
-rw-r--r--dev-python/phply/phply-1.2.5.ebuild33
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/phply/Manifest b/dev-python/phply/Manifest
new file mode 100644
index 000000000000..6675e28bf319
--- /dev/null
+++ b/dev-python/phply/Manifest
@@ -0,0 +1,3 @@
+DIST phply-1.2.5.gh.tar.gz 35624 BLAKE2B 99fe9704cef570ad3055fa6c5aaaaed866d3c41c1479efbd29bb3224ae666d2ba13ccca61e6d67a8a0da4542dec79b5fdd201254e1ad638de81fa762049f4d13 SHA512 f0e4d0a6d2dfad5163fb68660602482b6de58c0dbd60d8db2f1df0622a9da3cc24e5fd309299a4a9ccf7abde081644a9a91fac8a2800520859199060f4080dc4
+EBUILD phply-1.2.5.ebuild 795 BLAKE2B 93611bc17899023ebf42dc13f42ba66cf6d591efaaed81e39d6b7d54cad569459f74854547165c0d03c50f2acb93fcca40a049d236517bd7434ae2236561d6d2 SHA512 dd1eb4cc81c309305f7a4eb0d8358341852e124b6067cf5afd0dadc8fd9ffef167cd74d6c55e5acf6cee6f599c579b041be0cd20bb82387be7c47aa7c5810098
+MISC metadata.xml 364 BLAKE2B 32f89060e0ce7bed45287e0d206ba333b07888c7b32c6e76f916c7a153cab420440f4cc9a0b16e9747949339155ac013696f65ce4e4d7dbda69aede6fb8531f2 SHA512 67ec43a111b7cbdd46954b82baa2d528d2cd86d25f579500bc556069b67aa5055abf78dfc3c51afd095e282a240c295f5503ff5a1c0292a996d3f2315fbe27f5
diff --git a/dev-python/phply/metadata.xml b/dev-python/phply/metadata.xml
new file mode 100644
index 000000000000..5b25b95df30c
--- /dev/null
+++ b/dev-python/phply/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">phply</remote-id>
+ <remote-id type="github">viraptor/phply</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/phply/phply-1.2.5.ebuild b/dev-python/phply/phply-1.2.5.ebuild
new file mode 100644
index 000000000000..eddb961c4385
--- /dev/null
+++ b/dev-python/phply/phply-1.2.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Lexer and parser for PHP source implemented using PLY"
+HOMEPAGE="
+ https://github.com/viraptor/phply/
+ https://pypi.org/project/phply/"
+SRC_URI="
+ https://github.com/viraptor/phply/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ # namespace? seriously?
+ sed -i -e '/namespace_packages/d' setup.py || die
+ # prevent installing tests, turn phply back into normal package
+ mv tests/__init__.py phply/ || die
+ distutils-r1_src_prepare
+}